Changing the Python Version - Kit

Attempting to use an extension to run a docker workflow from omniverse. However, the embedded version of python that omni kit comes with doesn’t work with the python script written to run the extension. I have attempted to change the ‘pythonHome’ and ‘pythonPath’ variables (in the kit-core.json file) to point to another version of python on my system (as shown in the guide: Embedded Python — kit-sdk 103.1 documentation). This, however breaks create and now it will crash on launch. I have also attempted to point the variables to a conda env which worked for the original developer of the extension but has now broken for his too.

Thanks,
Will

Hi @william.smith-14! Welcome to the forums! Could you provide some more information?

  1. What Python version are you using?
  2. What OS are you running?
  3. Can you provide logs from the crash?

Here’s more info about where logs are located: How to Report an issue with Omniverse

Hi, thanks for the quick reply,

  1. I was using the latest python version 3.9 but also tried again with 3.6 (as I believe that that is the version kit uses but still didn’t work)
  2. Windows 10
  3. I have attached the latest kit log but it will only allow me to upload one file at a time - if there are any others you need, please let me know
    kit_20220622_112714.log (1.1 MB)

Also running an Laptop RTX 3080

Hi @william.smith-14. You can use a different Python interpreter than the one embedded with Kit, but it’ll still need to be at minimum the same major.minor version. (e.g. 3.7)