CLion install rised questions about Java for ARMv8 64 bits

Hi,

As usual, I’ve tried to install CLion on my Jetson TX1 Dev Kit to see if it was smooth enough or if I should use something else or via SSH.

The problem is that CLion relies on Java and I can’t seem to be able to have it working properly.

When using the openjdk-7 java, I get a message “Cannot find VM options file” followed by “32-bit JVM is not supported. Please install 64-bit version.”

When using the webupd8team PPA repo and oracle-java8-installer, java is not found (because wrong arch installed I think). I’ve also tried to build openjdk-8 from source, but it didn’t work, also complained about some 32bit/64bit stuff at some point (https://github.com/hgomez/obuildfactory/wiki/How-to-build-and-package-OpenJDK-8-on-Linux).

As anyone been able to have a working java ? It could help me get CLion to work and maybe others with their own java tools.

The TX1 doesn’t run 64-bit applications yet, it looks like CLion doesn’t support 32-bit OSes. Nvidia’s supposed to be coming out with Aarch64 software support sometime soon, although probably not very soon since it released 23.2 pretty recently.

What is available to work with on a TX1 then ? Except the good old vi(m) and such ? Eclipse maybe ? There is no nsight ? I didn’t found it

Yeah, Eclipse is probably your best bet, but I don’t think the Nvidia version of it is available on the TX1.

Well, when you install the TX1 with JetPack, it installs nsight on the JetPack host as well as the Tegra profiling tool.

I’m now working from the JetPack host VM with nsight and when I need to test (not compile only), I commit the changes from there and test on the TX1. I get Nsight to navigate between methods with F3 which is the main feature required to gain time for me.