Compiling examples Win7 64 Optix 3.0.1 Cuda5.0 CMake Error in configuration process

Hi,

I am trying to compile Optix examples. I downloaded and installed Optix 3.0.1. with Cuda 5.0 notebook edition on Windows 7 64 bit with CMake 2.8.10.2 and MS Visual Studio 2010 on my laptop. The pre-compiled samples work fine.

I tried to compile the samples with both Optix and Cuda 32 and 64 bit and also with Optix 3.0 but I keep on getting the same error when I press configure in CMake after putting the samples path and build path as shown here:
https://dl.dropboxusercontent.com/u/182829143/cmakeOptix3.0.1_32.jpg
the actual error message form CMake is:

“Error in configuration process, project files may be invalid.”

Any ideas what I may be missing?

Thanks,
Bernhard

Can you post the complete CMake error log please?

Plus, can you try to configure OptiX 64 with “Visual Studio 10 Win64” on CMake?

Hello,
I attached the contents of the CMakeError.log below.
I ll try to configure my system the way you suggest next.
Many thanks for your help,
Bernhard


Determining if the C compiler works failed with the following output:
Change Dir: C:/Users/bernhard/Documents/Visual Studio 2010/Projects/optix301/build/CMakeFiles/CMakeTmp

Run Build Command:c:\PROGRA~2\MICROS~2.0\Common7\IDE\devenv.com CMAKE_TRY_COMPILE.sln /build Debug /project cmTryCompileExec4022543123

Microsoft ® Visual Studio Version 10.0.30319.1.

Copyright © Microsoft Corp. All rights reserved.

1>------ Build started: Project: cmTryCompileExec4022543123, Configuration: Debug Win32 ------

1>Build started 16/08/2013 16:51:05.

1>PrepareForBuild:

1> Creating directory “C:\Users\bernhard\Documents\Visual Studio 2010\Projects\optix301\build\CMakeFiles\CMakeTmp\Debug”.

1>InitializeBuildStatus:

1> Creating “cmTryCompileExec4022543123.dir\Debug\cmTryCompileExec4022543123.unsuccessfulbuild” because “AlwaysCreate” was specified.

1>ClCompile:

1> Microsoft ® 32-bit C/C++ Optimizing Compiler Version 16.00.30319.01 for 80x86

1> Copyright © Microsoft Corporation. All rights reserved.

1>

1> cl /c /Zi /W3 /WX- /Od /Ob0 /Oy- /D WIN32 /D _WINDOWS /D _DEBUG /D “CMAKE_INTDIR=“Debug”” /D _MBCS /Gm- /RTC1 /MDd /GS /fp:precise /Zc:wchar_t /Zc:forScope /Fo"cmTryCompileExec4022543123.dir\Debug\" /Fd"C:/Users/bernhard/Documents/Visual Studio 2010/Projects/optix301/build/CMakeFiles/CMakeTmp/Debug/cmTryCompileExec4022543123.pdb" /Gd /TC /analyze- /errorReport:prompt testCCompiler.c /Zm1000

1>

1> testCCompiler.c

1>LINK : fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt

1>

1>Build FAILED.

1>

1>Time Elapsed 00:00:00.47

========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

This doesn’t look like an OptiX bug… CMake tested MSVC 2010 32 bit compiler and passed a .c source file to the linker. Obviously the COFF (Common Object File Format) couldn’t recognize the .c file as a .obj file so bailed out early and left CMake stalled.

Searching on the web for “CMake failure during conversion to COFF” spits out lot of results. Some excerpts which might solve your problem:

  • Install windows 7 SDK then also install VC-Compiler-KB2519277
  • Uninstall .NET 4.5 on your machine and re-install .NET 4.0 in order to get CMake to work (4.5 removes all of 4.0’s assemblies)

This is not an OptiX bug but rather an MS related issue which CMake (and unfortunately you) encountered.

Hi,

Great! Thanks! I had an issue with Net Framework 4.5 before but forgot about it.
No idea why I had Net Framework 4.5 installed. Maybe the VS2012 redistributable required it.
Uninstalling it required a reinstall of VS2010 though. Now the samples compile without problem.

Bernhard