Concern about NVIDIA driver installation

Hello all,
I have installed the driver 525 by using Additional driver GUI and then reboot.
Checking by “nvidia-smi” shows that the driver is properly installed and display its name (RTX 4080).
But when running “nvidia-settings” it shows me a blank window with “ERROR: Unable to load info from any available system”.

I have tried :

  • sudo prime-select nvidia → Not work
  • modifying the /usr/bin/prime-support to force prime overloading → work but only show Prime profile tab and still got “ERROR: Unable to load info from any available system”.

So my assumption is that the driver is not installed correctly or missing some crucial parts, is it correct ?
Please help me with this issue. This is my company PC needed for our project.
Thank in advance.

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Here is the bug log. Thank you.
And sorry for the attached image does not match with the version I mentioned. At first I installed ver 525 and then tried ver 535 (as the attached image show). None of them worked.
nvidia-bug-report.log.gz (415.8 KB)

And this system use AMD Ryzen 9 7900X so I don’t think the driver makes mistake chosing the GPU like Intel’s.

The nvidia driver is fine but there’s no monitor connected so I suspect you’re connecting from remote via xrdp or similar. This is running inside a virtual Xserver, not on the nvidia gpu.

Yes, I use it via xrdp. So can it be fixed ?

It depends on what you want to do with it. Please check if VirtualGL meets your requirements. Otherwise, set xrdp to connect direcly to the real Xserver, e.g. through x11vnc.

I use it to run Carla simulator which visualize car movement demo, have some issue like “OpenGL2ES1 is not availble at null”, so I think Nvidia incompatible driver is the root cause.
Thank you for your precious advices, I’ll try VirtualGL

One more question sir, so now my understanding is when using xrdp to remote to my company PC for rendering, the NVIDIA GPU of my company PC is not used, the rendering is performed inside virtual Xserver, is it correct ?


But when I check by nvidia-smi, it shows that there is a process of that rendering job.

There’s now a second Xorg process running on the nvidia gpu which was likely spawned by Carla and is used for rendering.

Just checked what graphics API Carla uses, it’s Vulkan-only.
so VirtualGL won’t help.

So how can I use it remotely now, just tried connect xrdp directly via x11vnc and now the screen is black. Hope you can help ?

You first need to switch from gdm to lightdm. Then x11vnc needs to be run as root.

Oh this is my company PC, do change to lightdm have potential risk ? Thank you.

Then you should check with the IT departement of your company.

Ok thank you a lot for all of this. Wish you all the best

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.