Cooling fan not working

When working with multiple cameras, I noticed that the AGX gets quite warm, but the fan does not activate. When trying to activate the cooler manually failed because the path is not present. ( echo 255 > /sys/kernel/debug/tegra_fan/target_pwm)
Also tried “jetson_clocks” but didn’t work.

Can someone help me further?
Best regards

The path has changed in recent L4T releases, it now /sys/devices/pwm-fan/target_pwm.

This should be managed automatically by temperature trip points, but if you want to force full speed fan:

sudo su
echo 255 > /sys/devices/pwm-fan/target_pwm
1 Like

hello sandro.steinhuber,

may I know which JetPack release you’re working with,
according to developer guide, Maximizing Jetson Xavier Performance.

Starting with release 32.4, jetson_clocks no longer sets maximum fan speed by default. If you prefer the old behavior, use the --fan option.

please include --fan options to configure fan to rotate at maximum speed.

1 Like

Thank you that worked

Currently i am running in JP 4.4