The fan is not running while hot and there is no access to the fan speed sysfs handle

I am using the Jetpack 4.2 installed with the SDK manager. Everything is ok but the fan is not running. I searched in this forum. Someone said the fan speed can be tuned manually through sysfs handle but I cannot even find it in the system.

bash: cd: /sys/kernel/debug/tegra_fan: No such file or directory

Does anyone come across this issue ?

Thanks for any help.

Hi vv_face,

Please refer to below topic as reference:
https://devtalk.nvidia.com/default/topic/1047060/jetson-agx-xavier/fan-management-xavier/post/5323584/#5323584

Thanks

I have checked that thread before. The problem is that there is no sysfs handle of “/sys/kernel/debug/tegra_fan” in the system.

The board is shipped recently and the Jetpack 4.2 is installed through the NVIDIA SDK Manager.

Hi vv_face,

At L4t BSP R32.1, it’s moved to other path

/sys/kernel/debug/tegra_fan/target_pwm changed to /sys/devices/pwm-fan/target-pwm

That’s mentioned at the thread I posted above.

Thanks

Hi Kayccc, I flashed my TX2 with Jetpack4.2. When I tried the following commands, the ternimal says “permission denied”, why?

sudo nvpmodel -m 0
echo 255 > /sys/devices/pwm-fan/target-fan

You may be lacking root permission. Try this:

sudo su
# Below R32.1
echo 255 > /sys/kernel/debug/tegra_fan/target_pwm
# Or this from R32.1
echo 255 > /sys/devices/pwm-fan/target-fan
exit

Yes, i have the same problem. @@ i flash my agx xavier with jetpack 4.2.1
Have you fixed it? :D

Thank you. :D

Type executing this command before:

sudo su