FAN did not work so that NX's temperature was too high

We found NX’s FAN did not work sometimes then the temperature is too high.

Jetpack 4.6 [L4T 32.6.1]

Issue is similar as Fan PWM is 0 when CPU/GPU temperature is over 80 - Jetson & Embedded Systems / Jetson Xavier NX - NVIDIA Developer Forums

@masenlin1

Could you follow the suggestions in #11 from above link to manually control the fan?
Let’s see whether it works or not.

manually control echo, target_pwm is working,echo 255 > /sys/devices/pwm-fan/target_pwm it can work, the fan will move to rotate again by setting the PWM ,
and more confusing thing is if we use some external fan blow on the chip, the temperature does some changes, the fan also can re rotate again.

any suggestion?

Could u share the cur_pwm here? when the temperature is over 80 or not under expectation.

issue is not very easy to duplicated , when issue happen i did not use command line to get PWM , only take picture , i think it is same

we have another module have gotten this same issue , any suggestion ?

@stephen.xi could your try to restart the fancontrol service to see if it will be came back to normal.
$ sudo systemctl restart nvfancontrol

Ok, we will do it when next time hit this issue

I try this command on NX with JetPack 4.6, and it return an error as “service not found”.
could you tell me which version this service exist? Does Jetpack 4.6 or NX support this service?

Please try with JetPack 5.x. Thanks

hello, I tried anthoer way to avoid this issue. and I run the following function on rc.local. But this issue happened again. Do you have any idea about this issue? I don’t think it would changed after i set fan work with max freq.

function set_jetson_clocks {
	sudo jetson_clocks --store
	sudo jetson_clocks --fan
}

function set_VIC_freq {
        echo on > /sys/devices/13e10000.host1x/15340000.vic/power/control
        if [ x$(cat /sys/devices/13e10000.host1x/15340000.vic/power/runtime_status) != xactive ];then
                echo "enable VIC work with max freq failed."
                exit 1
        fi
        echo userspace > /sys/devices/13e10000.host1x/15340000.vic/devfreq/15340000.vic/governor
        freq_array=($(cat /sys/devices/13e10000.host1x/15340000.vic/devfreq/15340000.vic/available_frequencies))
        echo ${freq_array[-1]} > /sys/devices/13e10000.host1x/15340000.vic/devfreq/15340000.vic/max_freq
        echo ${freq_array[-1]} > /sys/devices/13e10000.host1x/15340000.vic/devfreq/15340000.vic/userspace/set_freq
        echo auto > /sys/devices/13e10000.host1x/15340000.vic/power/control
}

my device is jetson xvaier NX, and work on JetPack 4.6

hello ly945,

please refer to Fan Mode Control session, did you have configure the fan operation mode as cool mode?

Yes, sure we set it to cool mode.

But the key here is we already set the FAN always running at PWM 255, which means the fan is not controlled by Fan mode, either “cool” or “quit”

The current setting we believe and watch is the FAN always set to 255 max , and in this configuration, we
still got fan stop at stress test ( for example, overnight) , any suggestions for it ? thanks
image

hello stephen.xi,

may I know what’s the real use-case, did you ran stress test overnight and observed fan issue?
please setup terminal to gather kernel layer logs for more details.

(post deleted by author)

Sure, the issue is rarely to be replicated, to be honest, we don’t know which testing case will trigger it to stop running, what we latest time got this issue, is somehow for same reason we do some test with a little bit heavy workload , I notice the fan is stopped and the CPU Freq is 115MHZ, next time I will upload kernel log

Hi,

If you require to have the fan at full speed, you can follow these steps:

Best regards,
Leon

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.