Fan PWM is 0 when CPU/GPU temperature is over 80

I found sometimes, when the CPU/GPU temperature is over 80(Celsius), the fan PWM is still 0. Then my NX device board’s CPU/GPU temperature is more and more high, at last cause the device power down.

My fan mode is quite.

Why the fan PWN is still 0 when the CPU/GPU temperature is very hight?

Which JetPack version you used? are you on custom design board or devkit?
We may need to try to investigate if can reproduce the error.

See below information:

  • NVIDIA Jetson Xavier NX (Developer Kit Version)
    • Jetpack 4.6 [L4T 32.6.1]
    • NV Power Mode: MODE_15W_6CORE - Type: 2
    • jetson_stats.service: active
  • Board info:
    • Type: Xavier NX (Developer Kit Version)
    • SOC Family: tegra194 - ID:25
    • Module: P3668 - Board: P3509-000
    • Code Name: jakku
    • CUDA GPU architecture (ARCH_BIN): 7.2
    • Serial Number: 1424920027702

Hi,
Could you try fan mode “cool” and check if the issue still exists? The modes are listed in developer guide

We can try cool mode. But the only difference between cool and quite mode should be just the trip point temperature and corresponding hysteresis, rigt?

Where is the code(driver or service) to handle the trip point temperature and corresponding hysteresis? Can we check some logs( If we have or we can enable some logs), or add more logs to debug this issue?

Hi,
Please check
Read the PWM fan RPM in Jetson NX - #5 by JerryChang

So cur_pwm is zero sometimes when temperature is over 80? Do you observe it on developer kit?

We checked /sys/devices/pwm-fan/target_pwm is 0 when the temperature is very hight, and the fan was not turned on. When I run command echo 255 > /sys/devices/pwm-fan/target_pwm, I saw the fan started to run.

I did not check the cur_pwm.

Hi,
target_pwm is for manual control. Please check this section

cur_pwm should show the current mode. Please check if it meets expectation in over 80 degree. If not please check the driver code

Though I did not check cur_pwm, I can see the fan was not rotating at all when the temperature is over 80.

If I want to set fan’s pwm, what is the best way to do it?

Hi,
You may manually control the fan by setting target_pwm