CPU cores drop to 4 from 8 on xavier

Our xavier running on maxn mode,some times it’s drop to 4 cores.
We encountered two such issues on different devices(dmesg1.txt and dmest2.txt)
first time boot of system,cpu0~cpu8 is normal,second time boot,CPU4~CPU8 is shutdown at 14 seconds while booting…

on dmesg2.txt,it’s looks like error happens when system running 12077 seconds:

dmesg1.txt (568.8 KB)
dmesg2.txt (174.1 KB)

$ jetson_release -v

  • NVIDIA Jetson AGX Xavier [16GB]
    • Jetpack 4.4 [L4T 32.4.3]
    • NV Power Mode: MAXN - Type: 0
    • jetson_stats.service: active
  • Board info:
    • Type: AGX Xavier [16GB]
    • SOC Family: tegra194 - ID:25
    • Module: P2888-0001 - Board: P2822-0000
    • Code Name: galen
    • CUDA GPU architecture (ARCH_BIN): 7.2
    • Serial Number: 1560521007957
  • Libraries:
    • CUDA: 10.2.89
    • cuDNN:
    • TensorRT:
    • Visionworks:
    • OpenCV: 4.1.1 compiled CUDA: NO
    • VPI: 0.4.4
    • Vulkan: 1.2.70
  • jetson-stats:
    • Version 3.1.1
    • Works on Python 3.6.9
      by special reasons,we can’t update jetpack verson to newer. Can anyone explain why and how to avoid it, thanks!

What is the result of nvpmodel -q when that error happened?

Honestly, your BSP is too old and could be some kind of old known issue.

nvpmode -q info:

yes ,our BSP is so old…,is the cpu core drop to 4 a known issue of Jetpack 4.4?

It’s expected you only get 4 cores as only MAXN and MODE_30W_ALL enable all CPU cores.
Take a look at /etc/nvpmodel/nvpmodel.conf and you will know it.

yes, I known MAXN and MODE_30W_ALL will enable all CPU cores. I just want to know what caused this issue; At last time,my system nvpmode is maxn. after reboot , it turned to MODE_15W_DESKTOP …

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.