Critical: Conflicts, & Unmet dependencies with cuda-repo-10-0-local-10.0.130-410.48 for Ubuntu 18.04.02 (since 26.02.2019)

Hello, dear support!

We use the cuda-repo-10-0-local-10.0.130-410.48 package in Ubuntu 18.04 with our software for pattern recognition.

Since yesterday, the package has ceased to be installed due to unmet dependencies, as a result of the study, it was discovered that the repository (http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/) was updated on 02/26/2019

Please respond to this signal.
In the meantime, I’m trying to find a solution.
Thanks a lot.

My installation procedure of nvidia driver and cuda:

rm /etc/apt/sources.list.d/cuda*
  apt remove nvidia-cuda-toolkit
  apt purge nvidia-* -yq

 apt-key adv --fetch-keys  http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/7fa2af80.pub
echo "deb http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64 /" > /etc/apt/sources.list.d/cuda.list

  aptitude install nvidia-driver-410  nvidia-modprobe -yq  
  apt-mark hold nvidia-driver-410

 wget -O cuda-repo-ubuntu1804-10-0-local-10.0.130-410.48_1.0-1_amd64.deb https://developer.nvidia.com/compute/cuda/10.0/Prod/local_installers/cuda-repo-ubuntu1804-10-0-local-10.0.130-410.48_1.0-1_amd64 

  dpkg -i cuda-repo-ubuntu1804-10-0-local-10.0.130-410.48_1.0-1_amd64.deb
  apt-key add /var/cuda-repo-10-0-local-10.0.130-410.48/7fa2af80.pub
  aptitude update -y
  aptitude install cuda -y
  
  export PATH=/usr/local/cuda/bin${PATH:+:${PATH}}
  export LD_LIBRARY_PATH=/usr/local/cuda/lib64${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}

Installation Log with unmet dependencies


http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/7fa2af80.pub

deb http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64 /" > /etc/apt/sources.list.d/cuda.list

Selecting previously unselected package cuda-repo-ubuntu1804-10-0-local-10.0.130-410.48.

(Reading database ... 200537 files and directories currently installed.)

Preparing to unpack cuda-repo-ubuntu1804-10-0-local-10.0.130-410.48_1.0-1_amd64.deb ...

Unpacking cuda-repo-ubuntu1804-10-0-local-10.0.130-410.48 (1.0-1) ...

Setting up cuda-repo-ubuntu1804-10-0-local-10.0.130-410.48 (1.0-1) ...

OK

Get: 1 file:/var/cuda-repo-10-0-local-10.0.130-410.48  InRelease

Ign file:/var/cuda-repo-10-0-local-10.0.130-410.48  InRelease

Get: 2 file:/var/cuda-repo-10-0-local-10.0.130-410.48  Release [574 B]

Get: 3 file:/var/cuda-repo-10-0-local-10.0.130-410.48  Release [574 B]

Get: 4 file:/var/cuda-repo-10-0-local-10.0.130-410.48  Release.gpg [833 B]

Get: 5 file:/var/cuda-repo-10-0-local-10.0.130-410.48  Release.gpg [833 B]

Hit http://ua.archive.ubuntu.com/ubuntu bionic InRelease

Get: 6 file:/var/cuda-repo-10-0-local-10.0.130-410.48  Packages [24.4 kB]

Hit http://ua.archive.ubuntu.com/ubuntu bionic-updates InRelease

Hit http://ua.archive.ubuntu.com/ubuntu bionic-backports InRelease

Ign http://ftp.fau.de/trinity/trinity-builddeps-r14.0.0/ubuntu bionic InRelease

Hit http://ftp.fau.de/trinity/trinity-builddeps-r14.0.0/ubuntu bionic Release

Hit http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic InRelease

Ign http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64  InRelease

Get: 7 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]

Hit http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64  Release

Fetched 88.7 kB in 1s (102 kB/s)

Reading package lists...

Building dependency tree...

Reading state information...

Reading extended state information...

Initializing package states...

Writing extended state information...

Building tag database...

Reading package lists...

Building dependency tree...

Reading state information...

Reading extended state information...

Initializing package states...

Writing extended state information...

Building tag database...

The following NEW packages will be installed:

  cuda cuda-10-1{a} cuda-command-line-tools-10-1{a} cuda-compiler-10-1{a} cuda-cudart-10-1{a} cuda-cudart-dev-10-1{a} cuda-cufft-10-1{a} cuda-cufft-dev-10-1{a} cuda-cuobjdump-10-1{a} cuda-cupti-10-1{a} cu

da-curand-10-1{a} cuda-curand-dev-10-1{a} cuda-cusolver-10-1{a} cuda-cusolver-dev-10-1{a} cuda-cusparse-10-1{a} cuda-cusparse-dev-10-1{a} cuda-demo-suite-10-1{a} cuda-documentation-10-1{a} cuda-driver-dev

-10-1{a} cuda-drivers{a} cuda-gdb-10-1{a} cuda-gpu-library-advisor-10-1{a} cuda-libraries-10-1{a} cuda-libraries-dev-10-1{a} cuda-license-10-1{a} cuda-memcheck-10-1{a} cuda-misc-headers-10-1{a} cuda-npp-1

0-1{a} cuda-npp-dev-10-1{a} cuda-nsight-10-1{a} cuda-nsight-compute-10-1{a} cuda-nsight-systems-10-1{a} cuda-nvcc-10-1{a} cuda-nvdisasm-10-1{a} cuda-nvgraph-10-1{a} cuda-nvgraph-dev-10-1{a} cuda-nvjpeg-10

-1{a} cuda-nvjpeg-dev-10-1{a} cuda-nvml-dev-10-1{a} cuda-nvprof-10-1{a} cuda-nvprune-10-1{a} cuda-nvrtc-10-1{a} cuda-nvrtc-dev-10-1{a} cuda-nvtx-10-1{a} cuda-nvvp-10-1{a} cuda-runtime-10-1{a} cuda-samples

-10-1{a} cuda-sanitizer-api-10-1{a} cuda-toolkit-10-1{a} cuda-tools-10-1{a} cuda-visual-tools-10-1{a} default-jre{a} default-jre-headless{a} freeglut3{a} freeglut3-dev{a} libcublas-dev{a} libcublas10{a} l

ibdrm-dev{a} libgl1-mesa-dev{a} libgles1{a} libglu1-mesa-dev{a} libglvnd-core-dev{a} libglvnd-dev{a} libnvidia-cfg1-418{ab} libnvidia-common-418{a} libnvidia-compute-418{ab} libnvidia-decode-418{ab} libnv

idia-encode-418{ab} libnvidia-fbc1-418{ab} libnvidia-gl-418{ab} libnvidia-ifr1-418{ab} libx11-xcb-dev{a} libxcb-dri2-0-dev{a} libxcb-dri3-dev{a} libxcb-glx0-dev{a} libxcb-present-dev{a} libxcb-randr0-dev{

a} libxcb-shape0-dev{a} libxcb-sync-dev{a} libxcb-xfixes0-dev{a} libxmu-dev{a} libxmu-headers{a} libxshmfence-dev{a} libxxf86vm-dev{a} mesa-common-dev{a} nvidia-compute-utils-418{ab} nvidia-dkms-418{ab} n

vidia-driver-418{a} nvidia-kernel-common-418{ab} nvidia-kernel-source-418{ab} nvidia-utils-418{ab} openjdk-11-jre{a} openjdk-11-jre-headless{a} x11proto-xf86vidmode-dev{a} xserver-xorg-video-nvidia-418{a}

0 packages upgraded, 95 newly installed, 0 to remove and 0 not upgraded.

Need to get 1640 MB of archives. After unpacking 4367 MB will be used.

The following packages have unmet dependencies:

 libnvidia-compute-410 : Conflicts: libcuda-5.0-1 which is a virtual package, provided by:

                                    - libnvidia-compute-415 (415.27-0ubuntu0~gpu18.04.2), but it is not going to be installed

                                    - libnvidia-compute-410 (410.78-0ubuntu1~gpu18.04.2), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-396 (396.54-0ubuntu0~gpu18.04.1), but it is not going to be installed

                                    - libnvidia-compute-390 (390.87-0ubuntu0~gpu18.04.2), but it is not going to be installed

                                    - libcuda1-340 (340.107-0ubuntu0~gpu18.04.1), but it is not going to be installed

                                    - libcuda1-304 (304.137-0ubuntu2), but it is not going to be installed

                                    - libnvidia-compute-418 (418.39-0ubuntu1), but 418.39-0ubuntu1 is to be installed

                                    - libnvidia-compute-410 (410.79-0ubuntu1), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-410 (410.72-0ubuntu1), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-410 (410.48-0ubuntu1), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-390 (390.77-0ubuntu0.18.04.2), but it is not going to be installed

                                    - libcuda1-340 (340.107-0ubuntu0.18.04.2), but it is not going to be installed

                                    - libnvidia-compute-390 (390.48-0ubuntu3), but it is not going to be installed

                                    - libcuda1-340 (340.106-0ubuntu3), but it is not going to be installed

Conflicts: libcuda-5.5-1 which is a virtual package, provided by:

                                    - libnvidia-compute-415 (415.27-0ubuntu0~gpu18.04.2), but it is not going to be installed

                                    - libnvidia-compute-410 (410.78-0ubuntu1~gpu18.04.2), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-396 (396.54-0ubuntu0~gpu18.04.1), but it is not going to be installed

                                    - libnvidia-compute-390 (390.87-0ubuntu0~gpu18.04.2), but it is not going to be installed

                                    - libcuda1-340 (340.107-0ubuntu0~gpu18.04.1), but it is not going to be installed

                                    - libnvidia-compute-418 (418.39-0ubuntu1), but 418.39-0ubuntu1 is to be installed

                                    - libnvidia-compute-410 (410.79-0ubuntu1), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-410 (410.72-0ubuntu1), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-410 (410.48-0ubuntu1), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-390 (390.77-0ubuntu0.18.04.2), but it is not going to be installed

                                    - libcuda1-340 (340.107-0ubuntu0.18.04.2), but it is not going to be installed

                                    - libnvidia-compute-390 (390.48-0ubuntu3), but it is not going to be installed

                                    - libcuda1-340 (340.106-0ubuntu3), but it is not going to be installed

Conflicts: libcuda-6.0-1 which is a virtual package, provided by:

                                    - libnvidia-compute-415 (415.27-0ubuntu0~gpu18.04.2), but it is not going to be installed

                                    - libnvidia-compute-410 (410.78-0ubuntu1~gpu18.04.2), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-396 (396.54-0ubuntu0~gpu18.04.1), but it is not going to be installed

                                    - libnvidia-compute-390 (390.87-0ubuntu0~gpu18.04.2), but it is not going to be installed

                                    - libcuda1-340 (340.107-0ubuntu0~gpu18.04.1), but it is not going to be installed

                                    - libnvidia-compute-418 (418.39-0ubuntu1), but 418.39-0ubuntu1 is to be installed

                                    - libnvidia-compute-410 (410.79-0ubuntu1), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-410 (410.72-0ubuntu1), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-410 (410.48-0ubuntu1), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-390 (390.77-0ubuntu0.18.04.2), but it is not going to be installed

                                    - libcuda1-340 (340.107-0ubuntu0.18.04.2), but it is not going to be installed

                                    - libnvidia-compute-390 (390.48-0ubuntu3), but it is not going to be installed

                                    - libcuda1-340 (340.106-0ubuntu3), but it is not going to be installed

Conflicts: libcuda-6.5-1 which is a virtual package, provided by:

                                    - libnvidia-compute-415 (415.27-0ubuntu0~gpu18.04.2), but it is not going to be installed

                                    - libnvidia-compute-410 (410.78-0ubuntu1~gpu18.04.2), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-396 (396.54-0ubuntu0~gpu18.04.1), but it is not going to be installed

                                    - libnvidia-compute-390 (390.87-0ubuntu0~gpu18.04.2), but it is not going to be installed

                                    - libcuda1-340 (340.107-0ubuntu0~gpu18.04.1), but it is not going to be installed

                                    - libnvidia-compute-418 (418.39-0ubuntu1), but 418.39-0ubuntu1 is to be installed

                                    - libnvidia-compute-410 (410.79-0ubuntu1), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-410 (410.72-0ubuntu1), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-410 (410.48-0ubuntu1), but 410.79-0ubuntu1 is installed

                                    - libnvidia-compute-390 (390.77-0ubuntu0.18.04.2), but it is not going to be installed

                                    - libcuda1-340 (340.107-0ubuntu0.18.04.2), but it is not going to be installed

                                    - libnvidia-compute-390 (390.48-0ubuntu3), but it is not going to be installed

                                    - libcuda1-340 (340.106-0ubuntu3), but it is not going to be installed
                         Conflicts: libcuda-7.0-1 which is a virtual package, provided by:
                                    - libnvidia-compute-415 (415.27-0ubuntu0~gpu18.04.2), but it is not going to be installed
                                    - libnvidia-compute-410 (410.78-0ubuntu1~gpu18.04.2), but 410.79-0ubuntu1 is installed
                                    - libnvidia-compute-396 (396.54-0ubuntu0~gpu18.04.1), but it is not going to be installed
                                    - libnvidia-compute-390 (390.87-0ubuntu0~gpu18.04.2), but it is not going to be installed
                                    - libnvidia-compute-418 (418.39-0ubuntu1), but 418.39-0ubuntu1 is to be installed
                                    - libnvidia-compute-410 (410.79-0ubuntu1), but 410.79-0ubuntu1 is installed
                                    - libnvidia-compute-410 (410.72-0ubuntu1), but 410.79-0ubuntu1 is installed
                                    - libnvidia-compute-410 (410.48-0ubuntu1), but 410.79-0ubuntu1 is installed
                                    - libnvidia-compute-390 (390.77-0ubuntu0.18.04.2), but it is not going to be installed
                                    - libnvidia-compute-390 (390.48-0ubuntu3), but it is not going to be installed
                         Conflicts: libcuda-7.5-1 which is a virtual package, provided by:
                                    - libnvidia-compute-415 (415.27-0ubuntu0~gpu18.04.2), but it is not going to be installed
                                    - libnvidia-compute-410 (410.78-0ubuntu1~gpu18.04.2), but 410.79-0ubuntu1 is installed
                                    - libnvidia-compute-396 (...

Thanks a lot!
Dmitro Makhonko