Cuda 12.2 not available on Docker hub?

Hi team

We are experimenting Jetson AGX Orin. It has Ubuntu 20.04 LTS installed. We want to create a docker container with Cuda and TensorRT. We are able to install Cuda 12.2 toolkit and Nvidia runtime. And with that we are able to run deviceQuery from Cuda sample. And it is giving correct output as well.
However when we are creating a container, we do not see 12.2 version of Cuda available from nvidia account on Dockerhub. Our understanding is; Nvidia uploads all the versions of Cuda toolkit on dockerhub. If that is the case, is there any plan on pushing 12.2 version?

If not, is there any other way to achieve this?

Hi,
Not sure if you use Jetpack 5.1.3 or 6.0DP. For Jetpack 5 releases, the CUDA is 11.4. And you may try 6.0Dp which is with 12.2
JetPack SDK 6.0 DP | NVIDIA Developer

We are using 5.1.2 and it has Cuda 11.4 as per the release note. But we can not see it after flashing with 5.1.2 SDK. So we had tried installing Cuda toolkit explicitly, and we were not able to run deviceQuery from Cuda sample. So we tried 12.4 and then 12.2. And with 12.2 it is working fine. But then this version itself is not available on dockerhub which is quiet strange. because only this version is missing.

Hi @kumar.gaurav4, check the l4t-cuda or l4t-jetpack containers on NGC:

Alternatively, there are CUDA dockerfiles in jetson-containers in which you can install desired CUDA version: https://github.com/dusty-nv/jetson-containers/tree/master/packages/cuda/cuda

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.