CUDA 2.3 Installation Help

Hello everybody, I’m a new member and wishing CUDA user, I’m trying to install CUDA 2.3 on MAC OSX Snow Leopard.

I downloaded and installed, in this order:

CUDA Driver: CUDA Driver 2.3.1 for use with Quadro FX 4800 or GeForce GTX 285 on MacOS X 10.5.2 or later (pre-SnowLeopard), and any NVIDIA GPU on SnowLeopard --> I have SnowLeopard so thought this was the best choice

CUDA Toolkit: CUDA Toolkit 2.3 for Mac OS

CUDA SDK: CUDA SDK 2.3 code samples for Mac OS

Visual Profiler: CUDA Visual Profiler v1.3 for Mac OS

But when installing Visual Profiler a message appears: “Unable to load the ‘/usr/local/cuda/lib/libcuda.dylib’ library. CUDA Visual Profiler device features will be disabled.”, where i can get it? Or what i have do to to make ev’thing running?

I also tried installation o Windows Xp running via VMware, but Visual profiler asked me for “nvcuda.dll”, i downloaded and put it in system32 and now appears “Cannot initialize CUDA”. What should I do know?

Thanks for reading, I hope somebody can help me.

Hmm, i dont know whats going wrong. I dont have that problem.

Maybe its on order of install the parts (driver, SDK, Tools) problem ?

At least for the 3.0x Version:

[b]1) Install CUDA toolkit

  1. Install CUDA driver

  2. Install CUDA SDK[/b]

The reason for this is that, while in step 1, the following file is installed: “/usr/local/cuda/lib/libcuda.dylib”, step 2’s installer package simply overwrites any existing /usr/local/cuda/lib/ folder with its own, which doesn’t include libcuda.dylib.

You can also try to use the new 3.0beta driver/tools/sdk, which should be better for running in SL (64 Bit).

The 2.3 stable cant use Snow Leopard in 64 Bit Kernelmode.

NV CUDO 3.0 beta (win,linux, MAC OS X)

http://forums.nvidia.com/index.php?showtopic=149959&st=0

I didn’t understand: I have to install 2.3 or 3.0? and drivers has to be installed before or after toolkit?

NO . First the toolkit, then the driver. Toolkit after driver overwites at least in 2.3 driver parts.

I tried but nothing changed. I saw that development’s folder with lib folder and the others appear only when SDK is installed, not before

Have you compiled the SDK? if not then once installed you need to open a terminal and navigate to /Developer/GPU Programs/C and use make

You might get this problem though… http://forums.nvidia.com/index.php?showtopic=154856

Are you sure that cuda 3.0 is 64 bit? I didn’t see any clear mention of that in the release notes. Can you confirm please?

Im pretty sure it is. I was able to successfully install/verify the installation by running the sample programs provided in the SDK with 3.0 on my 13" MBP (mid 2010) w/ GeForce 320M. I am trying to downgrade to 2.3(since the emulator mode ain’t working so hot for me in 3.0) and am getting a wrong architecture error when trying to make the SDK files.