CUDA 9.1 stopped working after upgrade to 416.34 drivers

Hello.

I am currently developing a CUDA 9.1 application on my Windows 10 (64 bit) ASUS Stratix (ROG) notebook with a GTX1060. This application works in tandem with a VR rig (Oculus Rift). Yesterday, the Oculus software required me to upgrade my GPU driver. I went to the NVIDIA site, got the latest driver (416.34) for my card – GTX1060 (Notebook). After installing the driver and rebooting, CUDA has completely stopped working. The HWMonitor application reports 0% GPU utilization, and my program no longer outputs anything.

We have tried this on other machines. The driver update worked on an MSI laptop with a 1070, and on a generic desktop with a 1080. Thus I suspect the problem is related to my specific hardware combination.

I’m stuck: either I can’t use the Oculus software, or I can’t develop my own application.

I don’t know where to begin to start figuring out what the problem is. Any suggestions on where to start?
Does anyone else out there have a system that is similar to mine?

Thanks!

https://devtalk.nvidia.com/default/board/58/cuda-setup-and-installation/

Thanks - are you suggesting that I post this thread on that topic instead?

Correct, this is where people who troubleshoot installation exchange some ideas.