CUDA does not find my gt210

Hi all,

I recently bought a Card with a gt210 GPU, but CUDA does not detect the card. Graphics work fine, including OpenGL, but when I run deviceQuery, all I get is:

CUDA Device Query (Runtime API) version (CUDART static linking)

There is 1 device supporting CUDA

Device 0: "Device Emulation (CPU)"

  CUDA Driver Version:						   2.30

  CUDA Runtime Version:						  2.30

  CUDA Capability Major revision number:		 1

  CUDA Capability Minor revision number:		 2

  Total amount of global memory:				 536150016 bytes

  Number of multiprocessors:					 2

  Number of cores:							   16

  Total amount of constant memory:			   65536 bytes

  Total amount of shared memory per block:	   16384 bytes

  Total number of registers available per block: 16384

  Warp size:									 32

  Maximum number of threads per block:		   512

  Maximum sizes of each dimension of a block:	512 x 512 x 64

  Maximum sizes of each dimension of a grid:	 65535 x 65535 x 1

  Maximum memory pitch:						  262144 bytes

  Texture alignment:							 256 bytes

  Clock rate:									1.40 GHz

  Concurrent copy and execution:				 Yes

  Run time limit on kernels:					 Yes

  Integrated:									No

  Support host page-locked memory mapping:	   Yes

  Compute mode:								  Default (multiple host threads can use this device simultaneously)


Press ENTER to exit...

I am running Ubuntu 9.04.

The card is listed in “lspci” as

20:00.0 VGA compatible controller: nVidia Corporation Device 0a65 (rev a2)

I checked the permissions of /dev/nv* and they are both 666. I even tried changing the owner to my user, but that did not help either.

Any ideas on what the problem is or how to debug it?




did you solve you problem?
I have the same problem with GTX285 on Debian 2.6.32-5 (Squeeze).
My driver is also installed:
2:00.0 VGA compatible controller: nVidia Corporation GT200b [GeForce GTX 285] (rev a1)
I have to add that i am running the machine without superuser rights.


That doesn’t mean that the driver is loaded. It just means the card has been enumerated on the PCI express bus and the version of pciutils you are using knows the PCI ID string of the card. Whether the driver is installed or working will have no effect on that output whatsoever.

What driver version are you using and where did you install it from? Are you running X11 on this box or not?