CUDA Driver Problems for Tesla S2050 with SLES 11 sp1

Hey everyone I am currently having problems running CUDA programs on an SGI UV 100 with a Tesla S2050. The examples that do not use OpenGL compile fine. When I run ./devicequery I get a CUDA Driver and Runtime version mismatch, and when I run some other examples I get a no CUDA capable device found. I have had no problems running CUDA programs under SLED and SLES on a workstation with a local Tesla C1070 card, but when I try to run them on the Tesla S2050 these problems occur. I currently have tried the newest Tesla driver 260.19.44 with Cuda 3.2. When I checked under /dev it does appear to show /dev/nvidia0 /dev/nvidia1 /dev/nvidia2 /dev/nvidia3 so the tesla box is connected properly. LD_LIBRARY_PATH and PATH are set correctly to /usr/local/cuda/lib64 and /usr/local/cuda/bin. My main question is if there is a special driver needed for the Tesla S2050? Do I install the drivers differently when using the server class hardware? What could be the cause of this?

Thanks

Exactly the same problem here using Archlinux and Tesla C2050.