Tesla c2050 with Scienctific Linux

Hi,
I am using two Tesla C2050 with Scientific Linux,
I succed to install devdriver_3.2_linux_64_260.19.26.run, and the cuda tookit cudatoolkit_3.2.16_linux_64_rhel5.5.run,
I solved the lib problems, I also was able to compile the codes in gpucomputingsdk_3.2.16_linux.run,
however, when I run the examples I got:

$./deviceQuery
./deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount FAILED CUDA Driver and Runtime version may be mismatched.

FAILED

Press to Quit…

I checked if the driver is loaded,

$lsmod | grep nvidia
nvidia 10280840 28
i2c_core 56641 3 i2c_ec,nvidia,i2c_i801

any help and clues?
thanks

If you are not running X11, then you will need to create the /dev/nv* entries for the driver. How to do this is described in the CUDA toolkit for Linux release notes.

Actually, I checked it

$ls -l /dev/n*
crw-rw-rw- 1 root root 1, 3 19 gen 12:11 /dev/null
crw------- 1 bouhadef root 195, 0 19 gen 12:12 /dev/nvidia0
crw------- 1 bouhadef root 195, 1 19 gen 12:12 /dev/nvidia1
crw------- 1 bouhadef root 195, 255 19 gen 12:12 /dev/nvidiactl
crw-rw---- 1 root root 10, 144 19 gen 12:11 /dev/nvram

Are you user [font=“Courier New”]bouhadef[/font]? If you want Cuda to work for other users as well, you’ll have to give everyody read&write access to the devices:

sudo chmod go+rw /dev/nvidia*

Yes I did as well.

chmod 0666 /dev/nv*

OTOH if you are not alone on your system you might consider removing world write access to /dev/nvram now. :smile: