CUDA error, bandwithTest.exe

Hi
I am attempting to install CUDA in order to run tensorflow on my computer, however I am experiencing some difficulty. I have looked in several forum posts, and can not find a solution

Install went fine, but when i try to run the tests specified in the install guide, i run into some obstacles.

running deviceQuery.exe works fine:

C:\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0\bin\win64\Debug>deviceQuery.exe
deviceQuery.exe Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: “GeForce GPU”
CUDA Driver Version / Runtime Version 9.0 / 9.0
CUDA Capability Major/Minor version number: 5.0
Total amount of global memory: 1024 MBytes (1073741824 bytes)
( 3) Multiprocessors, (128) CUDA Cores/MP: 384 CUDA Cores
GPU Max Clock rate: 993 MHz (0.99 GHz)
Memory Clock rate: 2505 Mhz
Memory Bus Width: 64-bit
L2 Cache Size: 1048576 bytes
Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096)
Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers
Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 49152 bytes
Total number of registers available per block: 65536
Warp size: 32
Maximum number of threads per multiprocessor: 2048
Maximum number of threads per block: 1024
Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535)
Maximum memory pitch: 2147483647 bytes
Texture alignment: 512 bytes
Concurrent copy and kernel execution: Yes with 1 copy engine(s)
Run time limit on kernels: Yes
Integrated GPU sharing Host Memory: No
Support host page-locked memory mapping: Yes
Alignment requirement for Surfaces: Yes
Device has ECC support: Disabled
CUDA Device Driver Mode (TCC or WDDM): WDDM (Windows Display Driver Model)
Device supports Unified Addressing (UVA): Yes
Supports Cooperative Kernel Launch: No
Supports MultiDevice Co-op Kernel Launch: No
Device PCI Domain ID / Bus ID / location ID: 0 / 1 / 0
Compute Mode:
< Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 9.0, CUDA Runtime Version = 9.0, NumDevs = 1
Result = PASS

BUT: When running bandwithTest.exe i get the following error message:

C:\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0\bin\win64\Debug>bandwidthTest.exe
[CUDA Bandwidth Test] - Starting…
Running on…

Device 0: GeForce GPU
Quick Mode

CUDA error at C:/ProgramData/NVIDIA Corporation/CUDA Samples/v9.0/1_Utilities/bandwidthTest/bandwidthTest.cu:837 code=6(cudaErrorLaunchTimeout) “cudaFree(d_idata)”

I get the passed score for device to device, and device to host, but host to device fails…:

C:\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0\bin\win64\Debug>bandwidthTest.exe --dtod
[CUDA Bandwidth Test] - Starting…
Running on…

Device 0: GeForce GPU
Quick Mode

Device to Device Bandwidth, 1 Device(s)
PINNED Memory Transfers
Transfer Size (Bytes) Bandwidth(MB/s)
33554432 34158.7

Result = PASS

NOTE: The CUDA Samples are not meant for performance measurements. Results may vary when GPU Boost is enabled.

C:\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0\bin\win64\Debug>bandwidthTest.exe --dtoh
[CUDA Bandwidth Test] - Starting…
Running on…

Device 0: GeForce GPU
Quick Mode

Device to Host Bandwidth, 1 Device(s)
PINNED Memory Transfers
Transfer Size (Bytes) Bandwidth(MB/s)
33554432 1613.6

Result = PASS

NOTE: The CUDA Samples are not meant for performance measurements. Results may vary when GPU Boost is enabled.

C:\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0\bin\win64\Debug>bandwidthTest.exe --htod
[CUDA Bandwidth Test] - Starting…
Running on…

Device 0: GeForce GPU
Quick Mode

CUDA error at C:/ProgramData/NVIDIA Corporation/CUDA Samples/v9.0/1_Utilities/bandwidthTest/bandwidthTest.cu:837 code=6(cudaErrorLaunchTimeout) “cudaFree(d_idata)”

Any help would be greatly appreciated!

  • Erlend

Hi,

I am experiencing the same error pattern. Does someone have a way forward?

Mario

C:\Users\mabou

“\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0\bin\win64\Debug\deviceQuery.exe”
\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0\bin\win64\Debug\deviceQuery.exe Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: “GeForce GTX 965M”
CUDA Driver Version / Runtime Version 9.0 / 9.0
CUDA Capability Major/Minor version number: 5.2
Total amount of global memory: 2048 MBytes (2147483648 bytes)
( 8) Multiprocessors, (128) CUDA Cores/MP: 1024 CUDA Cores
GPU Max Clock rate: 1150 MHz (1.15 GHz)
Memory Clock rate: 2505 Mhz
Memory Bus Width: 128-bit
L2 Cache Size: 1048576 bytes
Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096)
Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers
Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 49152 bytes
Total number of registers available per block: 65536
Warp size: 32
Maximum number of threads per multiprocessor: 2048
Maximum number of threads per block: 1024
Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535)
Maximum memory pitch: 2147483647 bytes
Texture alignment: 512 bytes
Concurrent copy and kernel execution: Yes with 2 copy engine(s)
Run time limit on kernels: Yes
Integrated GPU sharing Host Memory: No
Support host page-locked memory mapping: Yes
Alignment requirement for Surfaces: Yes
Device has ECC support: Disabled
CUDA Device Driver Mode (TCC or WDDM): WDDM (Windows Display Driver Model)
Device supports Unified Addressing (UVA): Yes
Supports Cooperative Kernel Launch: No
Supports MultiDevice Co-op Kernel Launch: No
Device PCI Domain ID / Bus ID / location ID: 0 / 1 / 0
Compute Mode:
< Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 9.0, CUDA Runtime Version = 9.0, NumDevs = 1
Result = PASS

C:\Users\mabou

“\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0\bin\win64\Debug\bandwidthTest.exe”
[CUDA Bandwidth Test] - Starting…
Running on…

Device 0: GeForce GTX 965M
Quick Mode

CUDA error at C:/ProgramData/NVIDIA Corporation/CUDA Samples/v9.0/1_Utilities/bandwidthTest/bandwidthTest.cu:837 code=6(cudaErrorLaunchTimeout) “cudaFree(d_idata)”

C:\Users\mabou

“\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0\bin\win64\Debug\bandwidthTest.exe” -dtod
[CUDA Bandwidth Test] - Starting…
Running on…

Device 0: GeForce GTX 965M
Quick Mode

Device to Device Bandwidth, 1 Device(s)
PINNED Memory Transfers
Transfer Size (Bytes) Bandwidth(MB/s)
33554432 66853.8

Result = PASS

NOTE: The CUDA Samples are not meant for performance measurements. Results may vary when GPU Boost is enabled.

C:\Users\mabou

“\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0\bin\win64\Debug\bandwidthTest.exe” -dtoh
[CUDA Bandwidth Test] - Starting…
Running on…

Device 0: GeForce GTX 965M
Quick Mode

Device to Host Bandwidth, 1 Device(s)
PINNED Memory Transfers
Transfer Size (Bytes) Bandwidth(MB/s)
33554432 1610.4

Result = PASS

NOTE: The CUDA Samples are not meant for performance measurements. Results may vary when GPU Boost is enabled.

C:\Users\mabou

“\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0\bin\win64\Debug\bandwidthTest.exe” -htod
[CUDA Bandwidth Test] - Starting…
Running on…

Device 0: GeForce GTX 965M
Quick Mode

CUDA error at C:/ProgramData/NVIDIA Corporation/CUDA Samples/v9.0/1_Utilities/bandwidthTest/bandwidthTest.cu:837 code=6(cudaErrorLaunchTimeout) “cudaFree(d_idata)”

cudaErrorLaunchTimeout usually means you are hitting a WDDM TDR on windows.

If you are building and running a debug version of the project (you are!), switch to building and running a release version of the project. Otherwise see here:

https://docs.nvidia.com/gameworks/content/developertools/desktop/timeout_detection_recovery.htm

Hi Robert,

Thank you. That can work. And it only works some of the time. For one thing, it seems I can’t be connected for a while to external monitors through a Surface Dock. (I’m doing this on a Surface Book with a GeForce GTX 965M.) Is that normal? And even when I’m not connected to the dock, I only get to a PASS two times out of three. Again, is that normal?

The kernel execution runtime is probably marginal, close to 2 seconds.

CUDA kernels when running on a WDDM GPU are not allowed to run for more than about 2 seconds. if they do so, they will be terminated with this error. That is normal.

https://docs.nvidia.com/gameworks/content/developertools/desktop/timeout_detection_recovery.htm

Thank you for this clarification.

Hi,

I have installed Visual Studio 2015 community edition, then installed Cuda 10.0.
When build and run the deviceQuery sample program, it works fine. But when I try to Running the bandwidthTest program, I got this error.

The command ““C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.0\bin\nvcc.exe” -ccbin “C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\x86_amd64” -x cu -I./ -I…/…/common/inc -I./ -I"C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.0/include” -I…/…/common/inc -I"C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.0\include" -G --keep-dir x64\Debug -maxrregcount=0 --machine 64 --compile -Xcompiler “/wd 4819” -g -DWIN32 -DWIN32 -D_MBCS -D_MBCS -Xcompiler “/EHsc /W3 /nologo /Od /FS /Zi /RTC1 /MTd " -o x64/Debug/cppIntegration.cu.obj “C:\ProgramData\NVIDIA Corporation\CUDA Samples\v10.0\0_Simple\cppIntegration\cppIntegration.cu” -clean” exited with code 1.

Any advice would be greatly appreciated.

That is compile output from the cppIntegration sample code. It has nothing to do with bandwidthTest. The question really has nothing to do with this thread.

Actually, the error remains same whether I compile cppIntegration sample code or bandwidthTest sample code. I posting my error again

The command ““C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.0\bin\nvcc.exe” -ccbin “C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\x86_amd64” -x cu -I./ -I…/…/common/inc -I./ -I"C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.0/include” -I…/…/common/inc -I"C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.0\include" -G --keep-dir x64\Debug -maxrregcount=0 --machine 64 --compile -Xcompiler “/wd 4819” -g -DWIN32 -DWIN32 -D_MBCS -D_MBCS -Xcompiler “/EHsc /W3 /nologo /Od /FS /Zi /RTC1 /MTd " -o x64/Debug/bandwidthTest.cu.obj “C:\ProgramData\NVIDIA Corporation\CUDA Samples\v10.0\1_Utilities\bandwidthTest\bandwidthTest.cu” -clean” exited with code 1. bandwidthTest C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\BuildCustomizations\CUDA 10.0.targets 889

when I just click on this error, the location of the error shown by the compiler is highlighted below in the file

This is a compile error. It has nothing to do with what is being discussed in this thread.

Thanks

Can you suggest me how to remove this compiler error?

I shall be very thankful.

Start a new thread. You’re getting a MSB3721 error. You need to increase the VS verbosity.