Cuda for Nvidia Shield TV

ubuntu has been successfully installed on $199 Tegra X1 based Shield TV:

I’m wondering if anyone has installed and run Cuda 7.5 on Shield TV.

Shield TV could be used for low cost Tegra X1/Cuda development.

See https://developer.nvidia.com/codeworks-android for CUDA 7.0 (for Android). Ubuntu on Shield is not formally supported.

Thanks for the info.

Unfortunately our customer requires Linux as OS.

If I can’t have Cuda work for Shield TV, I will have to wait for planned Jetson TX1 purchase.

Tegra X1 produced impressive performance with Ubuntu 15.04 on Shield TV:

https://www.phoronix.com/scan.php?page=news_item&px=NVIDIA-Tegra-X1-More-Tests

I ran “JetPack-L4T-2.0-linux-x64.run” on a Ubuntu laptop and was able to push Cuda 7.0 to a Shield TV with Ubuntu 14.04 LTS installed.

I was able to run Cuda 7.0 samples on the Shield TV (Tegra X1), the performance from SimpleMultiCopy is not as good as Cuda 6.5 on Chromebook CB5 (Terga K1).

I’ll try to optimize.

Hi, yahoo2016
I am your fans. I read your post in XDA forum about installing ubuntu on shield and I succeed too by following your steps. I install the ubuntu on shield 2015 by copying the rootfs file(L4T 24.2.1), after that I installed the cuda8.0, but I can’t run the cuda samples which seems like the cuda can’t recognise the nvidia GPUs.
What is the step that push cuda7.0 to shield by “JetPack-L4T-2.0-linux-x64.run”, I tried this method too, but I failed with some usb problems while flashing the t210ref to shield.
Could you help me?

It has been long time, as I recall, you can start “JetPack-L4T-2.0-linux-x64.run” finish host side installation and then select “install Cuda to target” without selecting “flash OS”. The installer will not tried to access SATV through USB but try to “push” Cuda through network. The Ubuntu host and SATV should be on the same network and you need to find IP address of SATV and pass the IP address of SATV to installer.

Thanks for your reply!
I reinstall the cuda as you said and it finally works.
The L4T version I use is R24.2.1, and have you ever tried a newer L4T version like R28.2? I notice that some person says the R24.2.1 is the last version can work on shield 2015 in XDA forum. Is that true? Maybe I should try it myself.

I and others tried to rebuild and install R28.1 kernel on SATV but failed. It appears R28.1 root file system works partially using R24.2.1 kernel. I believe the issue is dtb.
Nvidia removed dtb files for SATV (foster) from R28.x and started to use encrypted dtb since R28.2.
It may not worth the effort to try R28.x on SATV.

Yes, you are right. I tried R28.x and failed. What a pity.