Jetson tx2-4g r32.3.1 Missing Target Components

using sdkmanager to load Target Components fails with No space left on device.

need MultiMedia API

/usr/share is using 1.3G
/usr/lib is using 5.0G

This is what I have when I start the sdkmanager download
Filesystem Size Used Avail Use% Mounted on
/dev/mmcblk0p1 14G 11G 2.1G 84% /

Moved /opt/nvidia/deb_repos to my sd card, that moved 1.1G on to a seperate device.
Messed with and got
Filesystem Size Used Avail Use% Mounted on
/dev/mmcblk0p1 14G 9.8G 3.4G 75% /

sdkmanager still could not load Target components on to my tx2-4g, Nvidia needs to break up the target component install and make it work in a limited disk space.


if you could break “sdkmanager Target Components download” up, I could remove the cuda source during the procedure, if you put /usr/share and /usr/local on a diet, I might have enough disk space.

I need nvbuf_utils.h which was said to be in Multimedia api, so how about a sudo apt-get install multimedia-dev


So tried to install Target component on my tx2-8g got this.

08:23:05 SUMMARY: NVIDIA Container Runtime with Docker integration (Beta): Install completed successfully.
08:23:05 DEBUG: running command < true >
08:23:05 INFO: command finished successfully
08:23:05 DEBUG: Multimedia API: using adapter to install NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2_4GB to /home/tbuckley/nvidia/nvidia_sdk/JetPack_4.4.1_Linux_JETSON_TX2_4GB
08:23:05 INFO: Multimedia API: exec_command: ssh -t -q -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no tbuckley@ “df -B1 / | tail -1 | awk ‘{ printf $4 }’”
08:23:05 INFO: Multimedia API: exec_command: dpkg -f /home/tbuckley/Downloads/nvidia/sdkm_downloads/nvidia-l4t-jetson-multimedia-api_32.4.4-20201016123640_arm64.deb Package | tr -d ‘\n’
08:23:05 INFO: Multimedia API: **********************
08:23:07 INFO: Multimedia API: [target] [sudo] password for tbuckley:
08:23:07 : Multimedia API: Warning: Permanently added ‘’ (ECDSA) to the list of known hosts.
08:23:07 INFO: Multimedia API: [target] tbuckley@’s password:
08:23:08 INFO: Multimedia API: nvidia-l4t-jetson-multimedia-api_32.4.4-20201 0% 0 0.0KB/s --:-- ETA nvidia-l4t-jetson-multimedia-api_32.4.4-20201 100% 67MB 70.0MB/s 00:00
08:23:08 INFO: Multimedia API: **********************
08:23:09 INFO: Multimedia API: *begin sudo dpkg -i /opt/nvidia/deb_repos/nvidia-l4t-jetson-multimedia-api_32.4.4-20201016123640_arm64.deb, 5
08:23:09 INFO: Multimedia API: [target] [sudo] password for tbuckley:
08:23:10 INFO: Multimedia API: pre-dependency problem - not installing nvidia-l4t-jetson-multimedia-api
08:23:10 INFO: Multimedia API: /opt/nvidia/deb_repos/nvidia-l4t-jetson-multimedia-api_32.4.4-20201016123640_arm64.deb
08:23:10 ERROR: Multimedia API: command terminated with error
08:23:10 SUMMARY: Multimedia API: Failed to install debian package [target]

Also went from 13G to 18.8G used, so it will never load onto a tx2-4g, NVIDIA has a problem!

And I only need Multimedia, and it failed to install, :-(


Hi Terry,

SDK Manager installs target component with the following method:

  1. Copy component arm64.deb file to Jetson.
  2. Install this arm64.deb file on Jetson.
  3. Remove this arm64.deb file after successful installation.
  4. Go on with next target component installation.
    So it doesn’t take extra disk space during the installation.

When you install target components to Jetson TX2 with SDK Manager, could you please also flash Jetson TX2 in the same run? In a freshly flashed device, all target components can be installed.

Also there seems to be version mismatch in your log. In the title, it is r32.3.1, however, in the log, the Multimedia API version is “nvidia-l4t-jetson-multimedia-api_32.4.4”. BSP and target components must come from the same JetPack version. If Jetson is flashed with JetPack 4.3, however, later you want to install JetPack 4.4 target components on it, there will be compatibility issue.

too far into development to go back and do a fresh install, mipi dsi board, custom board support, and alot of work. Multiple drivers and such.

I think you are wrong about it working, but I will try, I have 3.8G free disk, I have an older sdkmanager, will try again,


I just need nvbuf_utils.h installed, is there an sudo apt-get install that can get me multimedia API


There are two NVIDIA Multimedia Packages that can be installed with apt-get install command:

If you only need this nvbuf_utils.h file, you could also extract the multimedia API debian file downloaded with SDK Manager on your host machine, then copy this file to your Jetson device.

For example,
dpkg -x <path_to_nvidia-l4t-jetson-multimedia-api_*_arm64.deb> .
find . -name nvbuf_utils.h

Thanks, that worked,

so need to download cuda, how much disk space do I need to add Target Componets.

It failed with 1.9G

Using sdkmanager 4.2.3 and cuda 10.0.x is being loaded. it runs out of disk space while adding cuda.


is there a way to install just cuda please?

looks like cuda-10.0 is using 1.4G what can I remove to allow cuda to run.


so got Reading package lists… Done
Building dependency tree
Reading state information… Done
libmnl0 is already the newest version (1.0.4-2).
libmnl0 set to manually installed.
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
cuda-toolkit-10-0 : Depends: cuda-documentation-10-0 (>= 10.0.326) but it is not going to be installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

did this ran out of disk space, tx2-4g r32.3.1, so what can I remove from the /usr/local/cuda-10.0 directory to free up disk space?

So now any sudo apt-get install fails, I really need diff packages loaded so I can do my development.

Is there anything in /usr/share and /usr/lib that can be removed to free up disk space?

No I can not reflash a base system. I ran for months and things went south when I thought I need cuda to use nvivafilter!



cuda-toolkit is the meta-package so it will install all the CUDA library including document, sample.
To customized CUDA installation, could you try to install the sub-library listed below based on your use case?

You should be able to find the similar CUDA library name for version 10.0 :

ii  cuda-command-line-tools-10-2                  10.2.89-1                                        arm64        CUDA command-line tools
ii  cuda-compiler-10-2                            10.2.89-1                                        arm64        CUDA compiler
ii  cuda-cudart-10-2                              10.2.89-1                                        arm64        CUDA Runtime native Libraries
ii  cuda-cudart-dev-10-2                          10.2.89-1                                        arm64        CUDA Runtime native dev links, headers
ii  cuda-cufft-10-2                               10.2.89-1                                        arm64        CUFFT native runtime libraries
ii  cuda-cufft-dev-10-2                           10.2.89-1                                        arm64        CUFFT native dev links, headers
ii  cuda-cuobjdump-10-2                           10.2.89-1                                        arm64        CUDA cuobjdump
ii  cuda-cupti-10-2                               10.2.89-1                                        arm64        CUDA profiling tools runtime libs.
ii  cuda-cupti-dev-10-2                           10.2.89-1                                        arm64        CUDA profiling tools interface.
ii  cuda-curand-10-2                              10.2.89-1                                        arm64        CURAND native runtime libraries
ii  cuda-curand-dev-10-2                          10.2.89-1                                        arm64        CURAND native dev links, headers
ii  cuda-cusolver-10-2                            10.2.89-1                                        arm64        CUDA solver native runtime libraries
ii  cuda-cusolver-dev-10-2                        10.2.89-1                                        arm64        CUDA solver native dev links, headers
ii  cuda-cusparse-10-2                            10.2.89-1                                        arm64        CUSPARSE native runtime libraries
ii  cuda-cusparse-dev-10-2                        10.2.89-1                                        arm64        CUSPARSE native dev links, headers
ii  cuda-documentation-10-2                       10.2.89-1                                        arm64        CUDA documentation
ii  cuda-driver-dev-10-2                          10.2.89-1                                        arm64        CUDA Driver native dev stub library
ii  cuda-gdb-10-2                                 10.2.89-1                                        arm64        CUDA-GDB
ii  cuda-libraries-10-2                           10.2.89-1                                        arm64        CUDA Libraries 10.2 meta-package
ii  cuda-libraries-dev-10-2                       10.2.89-1                                        arm64        CUDA Libraries 10.2 development meta-package
ii  cuda-license-10-2                             10.2.89-1                                        arm64        CUDA licenses
ii  cuda-memcheck-10-2                            10.2.89-1                                        arm64        CUDA-MEMCHECK
ii  cuda-misc-headers-10-2                        10.2.89-1                                        arm64        CUDA miscellaneous headers
ii  cuda-npp-10-2                                 10.2.89-1                                        arm64        NPP native runtime libraries
ii  cuda-npp-dev-10-2                             10.2.89-1                                        arm64        NPP native dev links, headers
ii  cuda-nvcc-10-2                                10.2.89-1                                        arm64        CUDA nvcc
ii  cuda-nvdisasm-10-2                            10.2.89-1                                        arm64        CUDA disassembler
ii  cuda-nvgraph-10-2                             10.2.89-1                                        arm64        NVGRAPH native runtime libraries
ii  cuda-nvgraph-dev-10-2                         10.2.89-1                                        arm64        NVGRAPH native dev links, headers
ii  cuda-nvml-dev-10-2                            10.2.89-1                                        arm64        NVML native dev links, headers
ii  cuda-nvprof-10-2                              10.2.89-1                                        arm64        CUDA Profiler tools
ii  cuda-nvprune-10-2                             10.2.89-1                                        arm64        CUDA nvprune
ii  cuda-nvrtc-10-2                               10.2.89-1                                        arm64        NVRTC native runtime libraries
ii  cuda-nvrtc-dev-10-2                           10.2.89-1                                        arm64        NVRTC native dev links, headers
ii  cuda-nvtx-10-2                                10.2.89-1                                        arm64        NVIDIA Tools Extension
ii  cuda-samples-10-2                             10.2.89-1                                        arm64        CUDA example applications
ii  cuda-toolkit-10-2                             10.2.89-1                                        arm64        CUDA Toolkit 10.2 meta-package
ii  cuda-tools-10-2                               10.2.89-1                                        arm64        CUDA Tools meta-package