Multimedia failed to install on TX2

Hi,

I have a system.img file that I use to flash my TX2. My software relies on the multimedia API / gstreamer to be correctly installed. However, it is failing to install one SDK component (Multimedia API) on the sdk manager. I tried to run the command on the tx2 as well, and get the same error saying “nvidia-l4t-core is not installed.”

I have flashed using the command
sudo ./flash.sh --no-systemimg jetson-tx2 mmcblk0p1

And it is not the first time I do it. Could someone help me fix that?
This is a tx2 production module being flashed on a tx2 dev kit carrier board, with an ubuntu 18.04 LTS host machine connected via micro usb.

Here is the part of the logs where it shows the problem.

11:14:11.274 - info: memInfo [total: 15.56GB, free: 3.29GB, available: 13.25GB]
11:14:11.275 - info: Event: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2 - install started
11:14:11.278 - info: estimated install timeout for NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP: 600s
11:14:11.296 - info: cmd finished success SDKM_END_CODE_SUCCESS_9ce3606b-0594-4bfc-8930-ab0a6e1b035c
11:14:11.296 - info: command finished successfully
11:14:11.333 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: exec_command: ssh -t -q -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no cinimod 192.168.55.1 “df -B1 / | tail -1 | awk ‘{ printf $4 }’”
11:14:11.434 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: [target] cinimod 192.168.55.1’s password:
11:14:11.434 - info: [TARGET PASSWORD]
11:14:11.450 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2:
11:14:11.795 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: Using GenericInstaller to Install NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP
11:14:11.795 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP include 1 package
11:14:11.812 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: [ Package Install Started ]
11:14:11.812 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: target deb installer start to install
11:14:11.812 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: exec_command: dpkg -f /home/dhstudio/Downloads/nvidia/sdkm_downloads/nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb Package | tr -d ‘\n’
11:14:11.812 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: exec_command: dpkg -f /home/dhstudio/Downloads/nvidia/sdkm_downloads/nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb Version | tr -d ‘\n’
11:14:11.822 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: deb file /home/dhstudio/Downloads/nvidia/sdkm_downloads/nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb, package name [nvidia-l4t-jetson-multimedia-api], package version [32.4.3-20200625213407]
11:14:11.823 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: infer package info from file name nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb [ name: nvidia-l4t-jetson-multimedia-api, version: 32.4.3-20200625213407 ]
11:14:11.832 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: exec_command [target]:
11:14:11.832 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: **********************
11:14:11.832 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: #!/bin/bash
11:14:11.832 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: set -e
11:14:11.832 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: export LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8 LANGUAGE=en_US.UTF-8
11:14:11.832 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: sudo mkdir -p /opt/nvidia/deb_repos
11:14:11.832 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: sudo chmod 777 /opt/nvidia/deb_repos
11:14:11.832 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: sudo rm -f /opt/nvidia/deb_repos/nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb
11:14:11.833 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: **********************
11:14:11.912 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: [target] cinimod @192.168.55.1’s password:
11:14:11.912 - info: [TARGET PASSWORD]
11:14:11.925 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2:
11:14:12.364 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: [target] cinimod @ 192.168.55.1’s password:
11:14:12.365 - info: [TARGET PASSWORD]
11:14:12.380 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2:
11:14:12.724 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: [target] [sudo] password for cinimod:
11:14:12.725 - info: [TARGET PASSWORD]
11:14:12.741 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2:
11:14:12.820 - warn: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: Warning: Permanently added ‘192.168.55.1’ (ECDSA) to the list of known hosts.
11:14:12.868 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: [target] cinimod @ 192.168.55.1’s password:
11:14:12.868 - info: [TARGET PASSWORD]
11:14:12.880 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2:
11:14:16.748 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2:
nvidia-l4t-jetson-multimedia-api_32.4.3-20200 0% 0 0.0KB/s --:-- ETA
nvidia-l4t-jetson-multimedia-api_32.4.3-20200 31% 21MB 20.9MB/s 00:02 ETA
nvidia-l4t-jetson-multimedia-api_32.4.3-20200 59% 40MB 20.7MB/s 00:01 ETA
nvidia-l4t-jetson-multimedia-api_32.4.3-20200 87% 59MB 20.6MB/s 00:00 ETA
nvidia-l4t-jetson-multimedia-api_32.4.3-20200 100% 67MB 19.0MB/s 00:03
11:14:16.767 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: exec_command [target]:
11:14:16.767 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: **********************
11:14:16.767 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: #!/bin/bash
11:14:16.767 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: set -e
11:14:16.767 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: export LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8 LANGUAGE=en_US.UTF-8
11:14:16.767 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: function safe_apt_install {
11:14:16.767 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: echo “*begin $1, $2”
11:14:16.767 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: tmp_log=/tmp/jetpack_dpkg_log.txt
11:14:16.767 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: sudo rm -f $tmp_log
11:14:16.767 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: set +e; $1 2>&1 | tee tmp_log; CMD_STATUS={PIPESTATUS[0]}; set -e
11:14:16.768 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: while [ ${CMD_STATUS} -ne 0 ]; do
11:14:16.768 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: if grep -q -e “is locked by another process” -e “E: Could not get lock /var/” $tmp_log; then
11:14:16.768 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: sudo rm -f $tmp_log
11:14:16.768 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: set +e; $1 2>&1 | tee tmp_log; CMD_STATUS={PIPESTATUS[0]}; set -e
11:14:16.768 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: echo "Waiting 2 seconds for apt to be available"; sleep {2}
11:14:16.768 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: else
11:14:16.768 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: echo “Unhandled error when running $1”; exit 1
11:14:16.768 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: fi
11:14:16.768 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: done
11:14:16.768 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: }
11:14:16.768 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: safe_apt_install “sudo dpkg -i /opt/nvidia/deb_repos/nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb” 5
11:14:16.768 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: sleep 5
11:14:16.768 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: sudo rm -f /opt/nvidia/deb_repos/nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb
11:14:16.769 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: **********************
11:14:16.844 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: [target] cinimod @ 192.168.55.1’s password:
11:14:16.844 - info: [TARGET PASSWORD]
11:14:16.862 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2:
11:14:17.268 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: [target] cinimod @ 192.168.55.1’s password:
11:14:17.271 - info: [TARGET PASSWORD]
11:14:17.286 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2:
11:14:17.609 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: *begin sudo dpkg -i /opt/nvidia/deb_repos/nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb, 5
11:14:17.624 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: [target] [sudo] password for cinimod:
11:14:17.624 - info: [TARGET PASSWORD]
11:14:17.632 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2:
11:14:17.764 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: Selecting previously unselected package nvidia-l4t-jetson-multimedia-api.
11:14:17.764 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: dpkg: regarding …/nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb containing nvidia-l4t-jetson-multimedia-api, pre-dependency problem:
11:14:17.765 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: nvidia-l4t-jetson-multimedia-api pre-depends on nvidia-l4t-core (>> 32.4-0)
11:14:17.765 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: nvidia-l4t-core is not installed.
11:14:17.765 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2:
11:14:17.765 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: dpkg: error processing archive /opt/nvidia/deb_repos/nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb (–install):
11:14:17.765 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: pre-dependency problem - not installing nvidia-l4t-jetson-multimedia-api
11:14:17.814 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: Errors were encountered while processing:
11:14:17.814 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: /opt/nvidia/deb_repos/nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb
11:14:17.831 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: Unhandled error when running sudo dpkg -i /opt/nvidia/deb_repos/nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb
11:14:17.831 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: [ Package Install Finished with Error ]
11:14:17.831 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: [ NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP Install took 6s ]
11:14:17.837 - error: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: [error]: dpkg install on target failed; [exec_command]: safe_apt_install “sudo dpkg -i /opt/nvidia/deb_repos/nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb” 5; sleep 5; ; [deb_path]: /home/dhstudio/Downloads/nvidia/sdkm_downloads/nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb
11:14:17.837 - info: Event: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2 - error is: [error]: dpkg install on target failed; [exec_command]: safe_apt_install “sudo dpkg -i /opt/nvidia/deb_repos/nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb” 5; sleep 5; ; [deb_path]: /home/dhstudio/Downloads/nvidia/sdkm_downloads/nvidia-l4t-jetson-multimedia-api_32.4.3-20200625213407_arm64.deb
11:14:17.837 - info: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2:
11:14:17.838 - error: cmd finished failure SDKM_END_CODE_FAILURE_bdcfeddd-d8d3-4082-961d-4be4832456b9_64
11:14:17.838 - error: command error code: 64
11:14:17.838 - info: Event: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2 - error code is: 1064
11:14:17.838 - error: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: command terminated with error
11:14:17.838 - info: Event: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2 - error is: command terminated with error
11:14:17.848 - info: Event: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2 - install ended - failure
11:14:17.848 - error: Session first failure occurred while Installing. Root cause component: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2. Root cause error code: (1064: Failed to install debian package [target])
11:14:17.849 - info: Summary: NV_L4T_MULTIMEDIA_API_TARGET_POST_INSTALL_T186_COMP@JETSON_TX2: Failed to install debian package [target]

Thanks

Hi,
We don’t observe the issue. Can you try to install system image and SDK components through SDKManager? It should work fine.