CUDA-GDB remote debugging "add connection" exception

i’m using Eclipse IDE for C/C++ Developers version 4.30, and cuda 11.4.

i’m trying to configure a remote debug session to my XAVIER NX, using CUDA-GDB remote debugging launcher.

in “remote connection” option, when i choose “add connection”:

i got the message “problem occured”:

(i can’t find log or any information on this fail)

also, that 2 “manage” buttons on the right, do nothing unfortunately.

please Advice.


Hi, @netanelt

Sorry for the issue you met.
Can you try using an older eclipse version or a newer cuda to have a try ?

Hi, yes.

I tried Eclipse 4.23 and Eclipse 4.19.
But when I tried to install Nsight-eclipse plugin from the jar, the installation failed for some reason (for both versions).

so I couldn’t reach to the cuda-gdb remote debugger configuration because plugin can not be installed…

Upgrading cuda will be more complicate for me I guess, since it installed by JetPack and not manually…

Hi, @netanelt
Can you use Nsight Eclipse Plugins Installation Guide to install ? Using the script instead of UI.

Yes, I tried the script also.
Looks like both versions installations fails from the same reason (this output is from 4.23 installation):

naty@naty-virtual-machine:/usr/local/cuda-11.4/bin$ ./ install /home/naty/Downloads/eclipse_4.23/eclipse

Installing Nsight EE plugins to /home/naty/Downloads/eclipse_4.23/eclipse…
SLF4J: Failed to load class “org.slf4j.impl.StaticLoggerBinder”.
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See SLF4J Error Codes for further details.
Installation failed.
Cannot complete the install because one or more required items could not be found.
Software being installed: CUDA Remote Launch (
Missing requirement: CUDA Remote Launch ( requires ‘org.eclipse.equinox.p2.iu; 0.0.0’ but it could not be found
There were errors. See log file: /home/naty/Downloads/eclipse_4.23/eclipse/configuration/1710402783417.log
Finished installation of Nsight EE plugins.

Full created log file is attached here:

1710403046829.log (61.7 KB)

I also tried to uninstall and install again from the script…

Hi, @netanelt

Thanks for trying and the output points you to SLF4J Error Codes
Can you check this page and try to fix your env ?

This link doesn’t help me unfortunately.

Do you think i should upgrade my cuda?
if so, is there a simple way to update cuda only?

I’m asking because my openCV compiled with this cuda, and want to do it in the right way…

Hi, @netanelt

You can try to get a latest CUDA run installer and install it directly on your machine.

Using the run installer(driver unselected) will not impact other package, it just will create another cuda folder.

But from the error info, I am not quite sure that you can resolve this by upgrading cuda.
Maybe you can try with our another plugin -, it can also support remote debugging.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.