Failed to connect sshd on Jetson Xavier NX

Hi,
I have a host jetson Xavier NX that I will want to connect with Nsight Eclipse SSH.
I work on my PC I have WSL2 Ubuntu and I install Cuda toolkit and nsight.
When I am trying to open a new Cuda project and connect SSH to the Xavier from nsight I get this error :
Failed to connect sshd on

attached to this meesage image:


I will be happy to help how I can solve this problem I want to use the cross-compile option.
When I try to connect SSH from my PC I succeed so it’s looks to me like some specific problem with the Nsight application maybe a setting or something that I missing.

Hi, @ariel27593

Can you please check if you can SSH to the Xavier board directly without Nsight Eclipse ?

@veraj
Thank you for reply,
Yes as I mention in the post I sucssed to connect Xavier board with ssh without Nsight Eclipse.

Oh, right. Sorry. We locally tried the remote access from WSL and it works. So can you clarify the steps you are executing in Eclipse ?

@veraj
Step1: write ‘nsight’ in command line (wsl2), this opreation open Nsight aplication.
step2: In Nsight aplication click left up botton File ->New->CUDA C/C++ Project
Step3: define empty project, use defualt setting, In target system I choose/config by Manage remote connection. (See figure 1)
Step4: Try choose project path (Figure2) connect to Xavier board and get error (Figure3)



@veraj
What is your opnion?

Hi, @ariel27593

You are using the nsight standalone application which has been dropped for a period.
I suggest you use Nsight Eclipse Plugin instead. 1. Introduction — Nsight Eclipse Plugins Installation Guide 12.3 documentation

@veraj
Thank you for reply, I work on windows computer with wsl2 ubuntu 16.04,
In the website Eclipse linux x64 installation support wsl or I going to run into problems ?
I sucssed to install eclipse when I run ./eclipse I get this error:
`
./eclipse (java:7428): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion ‘GDK_IS_PIXBUF (pixbuf)’ failed
(java:7428): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion ‘GDK_IS_PIXBUF (pixbuf)’ failed
(java:7428): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion ‘GDK_IS_PIXBUF (pixbuf)’ failed

(java:7428): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion ‘GDK_IS_PIXBUF (pixbuf)’ failed

(java:7428): Gtk-CRITICAL **: gtk_window_resize: assertion ‘width > 0’ failed

A fatal error has been detected by the Java Runtime Environment:

SIGSEGV (0xb) at pc=0x00007f54c1e4add6, pid=7428, tid=7429

JRE version: OpenJDK Runtime Environment Temurin-17.0.9+9 (17.0.9+9) (build 17.0.9+9)

Java VM: OpenJDK 64-Bit Server VM Temurin-17.0.9+9 (17.0.9+9, mixed mode, tiered, compressed oops, compressed class ptrs, g1 gc, linux-amd64)

Problematic frame:

C [libwayland-client.so.0+0x5dd6] wl_proxy_marshal_constructor+0x96

No core dump will be written. Core dumps have been disabled. To enable core dumping, try “ulimit -c unlimited” before starting Java again

An error report file with more information is saved as:

/home/ubuntu/eclipse_dir/eclipse/hs_err_pid7428.log

If you would like to submit a bug report, please visit:

Issues · adoptium/adoptium-support · GitHub

The crash happened outside the Java Virtual Machine in native code.

See problematic frame for where to report the bug.`

When I run with sudo I sucssed to open eclipse.
Now I try to Enter name (ex: NsightEE) in the Name field. Choose the the zip file(com.nvidia.cuda.repo.zip) that contains the plugins using Archive button or Enter the full path of zip file. Nsight EE plugns zip file can be found in /usr/local/cuda-11.8/nsightee_plugins directory

I get this error:


I would be happy to your help.

Hi, @ariel27593

We don’t have this issue internally. From your screenshot, it seems your input is cleaned ?

Can you please try installing again using script 1. Introduction — Nsight Eclipse Plugins Installation Guide 12.3 documentation ?

Also you are using 16.04 and cuda 11.8 ?
Can you update to newer version, like ubuntu 20.04/22.04 and cuda 12.3 ?

Ok, I succeeded in installing the new eclipse on my wsl2, my question is if I can work in cross-compile mode using wsl2?

Good to know ! Please refer 1. Introduction — Nsight Eclipse Plugins Guide 12.3 documentation for cross-compile steps.

I refer and see this The cross compilation mode is only supported on an Ubuntu x86 host system. sooo that mean that I can’t work in cross-compile mode with wsl? or Yes becuase for my is not so clear from the document my pc is x86 but with venv wsl

It should work as long as you have the cross compile toolchain installed successfully.