nsight not working with me

Anyone successfully launch nsight from the Ubuntu 18.04 host ?
Just wonder if something is wrong with my setup.

Hi sato5312,

Do you mean Nsight Eclipse plugins edition / NVIDIA Nsight Systems / NVIDIA Nsight Graphics ?

Yes

nsight

The NVidia logo came up, turned blank, then just hang there
vs with Jetpack 3.0 on tk1, the whole application launched successfully

Hi,

Do you install Nsight with JetPack4.0?
If not, could you give it a try?

Thanks.

Hi
Thanks for your responds
I think ‘nsight’ was installed by JetPack4.0, automatically
I expected this special NVidia edition of eclipse will let me connect and debug Cuda apps on the target Xavier
Did I miss something.

I appreciated your help
Thanks

Hi,

Could you share where you launch the Nsight tool?

Please remember that Nsight doesn’t support Jetson environment.
You need to launch it on an x86 desktop and cross-compiling the Jetson app.

Thanks.

Hi

I launch nsight from Ubuntu 18.04 on my laptop, which is the host to flash the Xavier module

Thanks

Hi. Same problem.

I’m on Ubuntu 18.04 and installed with the JetPack 4.0 Early Access.

I’m familiar with C++ and CUDA but not Linux.

It prompted that an error occurred and to check a log file “.metadata/.log” which is a hidden file. This may help you. I’m currently working through it.

Ok, I looked around, and I found a solution for my config:
https://stackoverflow.com/questions/41068508/cannot-launch-nvidia-nsight

This thread advises the following commands:
sudo apt install python-software-properties
sudo add-apt-repository ppa:webupd8team/java
sudo apt update
sudo apt install oracle-java8-installer

The install python step did not work, so I skipped it. I originally tried java10 installation since that thread is a little older. That didn’t work.

I installed java8 just as suggested, and it did the trick.

Hope this helps!

Hi,

I successfully launch nsight from ubuntu 18.04 after executing the following commands :

1. check if openjdk installed
$ java --version
openjdk 10.0.2 2018-07-17
OpenJDK Runtime Environment (build 10.0.2+13-Ubuntu-1ubuntu0.18.04.2)
OpenJDK 64-Bit Server VM (build 10.0.2+13-Ubuntu-1ubuntu0.18.04.2, mixed mode)

 If nothing showed then
  $ sudo apt-get install default-jre

2. config java for jre
$ sudo update-alternatives --config java
There are 2 choices for the alternative java (providing /usr/bin/java).

 Selection    Path                                            Priority   Status
 ------------------------------------------------------------
 * 0            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1101      auto mode
   1            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1101      manual mode
   [b]2            /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java   1081      manual mode

[/b]
Press to keep the current choice, or type selection number:

<b> Let select 2 to activate JRE</b>

Good luck

2 Likes

Hi mick.honey and ndnparis
Thanks for sharing your solution
I will try that next

OK. I got the “C/C++ - Nsight” window up
your guys are very helpful
but I am not done yet, until I can step debug one of the cuda example on the module

wow, too complicated, not a turn-key task, I will pursuit later
Thanks all.

Nothing of above worked for me. See my link below. I suppose that is still an open issue

https://devtalk.nvidia.com/default/topic/1047120/cuda-setup-and-installation/white-logo-screen-with-nsight-loading-and-stall/

CUDA 10
Ubuntu 18.04

Luis Gonçalves

Hi, luisgo

Could you share more information with your environment?

Is your host CUDA toolkit installed from JetPack or our website?
And do you have multiple CUDA toolkit installed on your environment?

THanks.

Sorry, somehow I solved the problem.

I do not use JetPack. It is for the RTX2070.

Some setting in BIOS.

Thanks

Luis Gonçalves

The computer has several boot partitions.

My boot partition is only used by me. I done several packages upgrades supposing that was the problem.

Then a colleague put the grub to boot the partitions. I suppose that the Boot Option was “Boot ROM” and passed to “UEFI” or both (in BIOS). Perhaps some option in Grub. My Ubuntu was installed with “Boot ROM” option

I will see later when I have some time

It is not the first time I had this problem

The solution to the problem is in the link below, but basically you have install Java Runtime Environment 8 on your system and launch the nsight with a special command tag as outlined in the nvidia user guide. Hope this helps.

https://cudaeducation.com/nsightlauncherror/

-Cuda Education
cudaeducation.com

Hi Luis,

What was the setting in BIOS that fixed the problem?

-Cuda Education
cudaeducation.com