CUDA installation failed

I have to install CUDA 9.0 for Machine Learning. I have installed Python 3, Anaconda, PyCharm, and VS 2017 Community(Only root files, not any workloads installed). There is only CUDA 9.0 that needs to be installed. In first installation of CUDA 9.0 I get an information which says that there is no Visual Studio installed. I checked the checkbox and started to progress. It failed. Then I installed VS 2017 Community without any workloads and tried install CUDA 9.0 again. I didn’t get information for VS, started progress, failed.

Should I install any workload which means about C++?
Should I give up installing CUDA 9.0?
What should I do? Work with processor? I want speed.

Nvidia GeForce GTX1050 Ti 4GB VRAM (Version: 398.11 - Updated)
Directx 12
Windows 10 64 bit Education
Intel Core i7-7700HQ 2.80 GHz (8 CPUs)

Hi, onurturali

Sorry you have met this.
This seems like the issue dev are working now.
The possible workaround is to delete C:\Program Files\NVIDIA Corporation\Installer2 and then install again.

If this still not work for you, please move the topic to CUDA set up and installation part, they should have more details to help.
Thanks !

I moved topic to the CUDA set up and installation part. By the way NVIDIA Corporation folder does not contain Installer2.