CUDA not seen in /usr/local ...OpenCV installation not working on Jetson TX2

I want to create a python environment and install opencv and other libraries to this environment to work on Yolov3 object detection. I installed jetpack 3.3 and it did not come with cuda preinstalled.I checked in /usr/local and does not show cuda installed. Tried to flash the board quite number of times now but does not work either, tried to do apt-get search cuda did not show any path.

Jetpack Installation followed this https://docs.nvidia.com/jetson/archives/jetpack-archived/jetpack-411/index.html#jetpack/4.1.1/install.htm%3FTocPath%3D_____3

Reference for OpenCV installation https://jkjung-avt.github.io/opencv3-on-tx2/

Any suggestions would be highly appreciated…Thanks

FYI, flash never installs extra packages. Once flash completes, then a pristine new system reboots…and only then can packages be added (this is over networking). You can uncheck flash, and then do only package installs at any later date. Just make sure wired ethernet is connected (there is a newer option in SDK Manger to use wired networking over USB…it’s still networking, but you wouldn’t need an ethernet cable), the Jetson is fully booted and not in recovery mode, and that you know the IP address of the Jetson (use “ifconfig”…the host might need extra steps if you use SDK Manger and the option of ethernet over USB).

Only after a flash is IP address discovery automated. When just adding packages and unchecking flash expect to enter the IP address when prompted. There are various options at the start of install as to the kind of network connection, so look closely for anything related to network options.

Hi,

Python OpenCV can be installed with this command:

sudo apt-get install python-opencv
sudo apt-get install python3-opencv

Thanks.

@linuxdev :Thank you for the response.
When i flashed the TX2 using the jetpack 3.3 installer…it boots but the problem arises when i want to install opencv for computer vision which has to do with cuda as per https://jkjung-avt.github.io/opencv3-on-tx2/…CUDA as per the jetpack 3.3 should be come prepackaged but in my case i did not find it installed…when i try to install it did not work either…Please let me know if i am missing out on something here or i could be wrong…thanks in advance (I am a newbie,thanks for your patience.)

@AastaLLL : I will try to install it on Jetpack 4.2 and get back to you, but i would like to work with jetpack 3.3 for ubuntu 16.04 but honestly,I am not really sure which works best for object detection tasks

@ AastaLLL :I tried to install using

sudo apt-get install python3-opencv

but did not work it returns the error as show in the image

https://ibb.co/rtw3TZw

FYI, CUDA does not come preinstalled after a flash. The package additions step after flash is complete (or if flash is not performed) adds that, but you have to have networking up and the Jetson fully booted.

Run JetPack again (I am assuming JetPack3.3, not SDK Manager…but you could do similar with SDK Manager…options differ some), connect wired ethernet, no USB (unless you pick ethernet over USB), no recovery mode, uncheck flash, and just pick components to add to the Jetson. I suggest you do this first with only CUDA installed. Then start the process again and add components which depend on CUDA (CUDA is the parent requirement for most everything, and if you get that one component started, then you know the rest can work).

I don’t know much about the Python and OpenCV installation, but it is highly likely these too would require CUDA to be installed first for a case where it is GPU accelerated.

Does installing just CUDA work?

Hi,

Would you mind to use JetPack 4.2 instead?
https://developer.nvidia.com/embedded/jetpack

python-opencv and python3-opencv is pre-installed in the JetPack4.2.
You can use it directly after installation.

Thanks.

@AastaLLL
I have installed 4.2 now and cuda comes along with it but now the issue is it doesnot connect to internet
and other issue is my camera doesnot work with ubuntu 18.04 (could be due to driver issue)

@linuxdev
I tried to install cuda alone which did not work either

got the internet issue resolved by manually setting the ip address but the camera is still an issue… i connected the MIPI but does not work

Hi,

Thanks for your update. Networks access is required for installing the packages.
For the camera issue, it’s recommended to file an anther topic for it.

Thanks.