CUDA on computer with TESLA as a General purpose device

Hi friends!

I have a computer with integrated ASPEED graphics and TESLA C1060. ASPEED is being used for display while TESLA is intended for general purpose programming only. I have CUDA Toolkit 3.2 with the latest development driver from Nvidia installed.

Is it possible to run CUDA on TESLA C1060 with the current configuration? I have tried running it in MATLAB but get an error ‘An error occured during: setting up the CUDA device. The CUDA error was: (Unknown code: 10100)’.

Any help will be highly appreciated.

Thanks

you can list the cuda-able graphic cards , then choose one.

Hi!

Can you run the DeviceQuery SDK example?

What OS are you using?

Are you using the TCC drivers for the Tesla Card?

Thanks for your reply. I have tried to do that but as NVidia Control Panel refuses to run (because main GPU is non-Nvidia), I could not do it that way. Not sure if there is another way.

Thank you for your reply.

As I am at very initial level so I have only tried to run it with MATLAB R2010b using gpuDevice command which gave me the error message I mentioned above. I have tried the same command on Thinkpad T510 having NVS 3100 Nvidia graphics card successfully.

The operating system on the computer is Windows 7. It also has Windows XP giving the same result.

I did not know about the TCC drivers for Tesla. Your suggestion regarding using TCC is a ray of hope. I have just read its document and it says that it needs Windows Server 2008. Will it work with Windows 7 or XP? I will try it though.

I appreciate you ( and huangshuojch) taking time to reply. Wish to hear from you with more precious suggestions.

Many Thanks

Hi!

TCC works with Win 7.

TCC comes with the nvidia drivers already, you just have to enable it.

To enable TCC mode on the GPU, you have to run the nvidia-smi.exe located somewhere on your computer.

Run it through cmd:

cd “to path where nvidia-smi.exe is located”

nvidia-smi.exe -g 0 -dm 1

0 stand for GPU 0 and 1 is for TCC mode.

Observe that TCC only works for Tesla and Quadro cards.

Another way to get CUDA running is to attach the monitor on the Tesla GPU (if you have an output).

With a monitor attached, you would not be able to use TCC mode.

See also this thread: http://forums.nvidia.com/index.php?showtopic=181864

Thank you for such a detailed reply:

I downloaded latest Tesla driver from Nvidia and this download page:

http://www.nvidia.com/object/tesla-win7-winvista-32bit-263.06-whql-driver.html

Once downloaded, I performed a clean install of the driver. However, I could not locate nvidia-smi.exe on my computer. I googled and found that it was cupposed to be in C:\Program Files\NVIDIA Corporation\NVSMI\nvidia-smi.exe. However, I could not find NVSMI in NVIDIA Corporation even after unhiding hidden files and performing a full search on my computer. Is it to be downloaded seperately? Am I making a mistake.

Thank you for your co-operation

With the help of one of the moderators (tmurray), I have come to know that TCC driver does not work with Windows 7 32-bit and hence don’t have nvidia-smi.exe or NVSMI folder. So I installed Windows 7 64-bit with latest TCC drivers for Tesla C1060 and now its up and running. Thanks tmurray.