CUPTI error not compatible

I have:
GTX 960
windows 10 64bit, 20H2, 19042.804
When nvidia visual profiler finished i got the error:
“Unable to profile application. com.nvidia.viper.jni.CuptiException: CUPTI_ERROR_NOT_COMPATIBLE”
I search many solution and i put in user path and system path of windows:
C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v11.2\extras\CUPTI\lib64
But i still have the same problem.


Did you attempt to collect the timeline, or you are interested in metrics analysis? Can you please run below nvprof commands and post the error/warning messages (if any):
nvprof <application>
nvprof --events active_cycles <application>
nvprof --analysis-metrics <application>

Thank you for your reply.
The first and second command completed without any error.
The third command give me:
“======== Error: An output file needs to be specified for “–source-level-analysis” or “–analysis-metrics”.
======== Use “nvprof --help” to get more information.”

Please check and this problem that i posted and maybe has related.

I noticed that there was an older version of the visual profile on my system.
Perhaps from an older installation of the different.
I had uninstalled this installation but it probably left some trash behind.
When I put the new version separately it did not change my shortcuts in the windows menu.
So i was running the old 10.x version of profiler.
I found it when today I decided to reinstall the cuda after delete the folder with 10.x.

Now the visual profiler runs without problems in sample code.
Tomorrow I will try it with my project.

Thank you all.

One last question.
What i must run?
Visual Profiler.bat from C:\ProgramData\Microsoft\Windows\Start Menu\Programs\NVIDIA Corporation\CUDA Toolkit\v11.2
nvvp.exe from C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v11.2\libnvvp

The .bat set the path for lib that i add it manually.
The .bat is the only shortcut of visual profiler in nvidia group icon in windows menu.
Now i run the .exe and work perfect.
I don’t know if it need the paths in system and if the installation add it automatically.


Good to hear that you could resolve the issue. Does it also solve the other issue this problem reported by you?

You can use either of the .bat file or .exe. As you must have spotted the difference that .bat adds a path to the CUPTI library (cupti.dll) before launching the nvvp.exe. NVVP uses dynamic CUPTI library, so it should be in the PATH environment variable before launching the nvvp.exe. CUDA toolkit installer doesn’t add the path to the CUPTI library in the PATH.

I wanted to use the profiler to analyze the code. So because my visual profiler was not running I tried from command line. I would prefer to use the visual profiler. I do not find the reason to use the commands from the command line. I think the command line has nothing more to offer me than the visual profiler.

Right, you can continue to use NVVP for performance analysis. It is layered on top of the command line tool nvprof for collection of the tracing and profiling data, and it offers a super-set of features supported by nvprof.

I want to double check it - have you stopped seeing the issue as reported in the post this problem after clean installation of the CUDA toolkit and NVVP?

I checked it and work perfect.
The nvprof create both nvvp file from the first command
and a second analysis-metrics nvvp from the second.
Both files opened without problem with visual profiler.

I did not make clean install of cuda.
I deleted the old folders from the old and uninstalled version of cuda 10.x
and reinstall the cuda installer.

Thanks for the confirmation.