Custom TX2i carrier, periodic error message

I am using a TX2i on my custom carrier. After booting I get this error message about every 10 seconds:

[   41.802834] tegra-i2c 3190000.i2c: rx dma timeout txlen:28 rxlen:128
[   41.809358] tegra-i2c 3190000.i2c: --- register dump for debugging ----
[   41.816123] tegra-i2c 3190000.i2c: I2C_CNFG - 0x22c00
[   41.821242] tegra-i2c 3190000.i2c: I2C_PACKET_TRANSFER_STATUS - 0x10001
[   41.827911] tegra-i2c 3190000.i2c: I2C_FIFO_CONTROL - 0x1c
[   41.833426] tegra-i2c 3190000.i2c: I2C_FIFO_STATUS - 0x800040
[   41.839198] tegra-i2c 3190000.i2c: I2C_INT_MASK - 0x6c
[   41.844356] tegra-i2c 3190000.i2c: I2C_INT_STATUS - 0x2
[   41.849622] tegra-i2c 3190000.i2c: i2c transfer timed out addr: 0x50
[   52.042850] tegra-i2c 3190000.i2c: rx dma timeout txlen:28 rxlen:128

This seems to be an error querying The HDMI port for EDID data. In my custom carrier there is no HDMI port. I can’t simply strip the HDMI support from the DT though, because then I wouldn’t be able to complete the initial Linux configuration. I flash the board and configure it using the NVIDIA carrier, then move the TX2i over to my carrier.

Is there a way to stop this periodic error while maintaining support for HDMI when installed on the NVIDIA carrier?

Thanks,
Jon

You should disable HDMI if there is no HDMI port on your board.

There are alternatives to finish the configuration… otherwise none of customers is able to do the headless setup.

Method 1. Connect usb to the flash port over your jetson and your host, there should be a “/dev/ttyACM0” device shown on your host side. Open it with serial tool and you shall see a screen as “Headless Mode Flow in oem-config” section in below page.

https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/flashing.html#wwpID0E03E0HA

Method 2. Before doing the flash, following the " Skipping oem-config" section in below page.

https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/flashing.html#wwpID0E03E0HA

Thank you Wayne, headless configuration is absolutely what I should be doing. Thank you for the quick response.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.