DeepStream 4.0 Can not run samples app on AGX Xavier (libnvinfer.so.5 No such file or directory Error)

Hi,
I flashed JetPack 4.3 and installed all components via SDK Manager and successfully run cuda and visionworks samples.

but when I tried to run deepstream sample app inside (opt/nvidia/deepstream/deepstream-4.0/samples/configs/deepstream-app)

by using this command

deepstream-app -c source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt

I got this error

deepstream-app: error while loading shared libraries: libnvinfer.so.5: cannot open shared object file: No such file or directory

I also tried to run other config file but I got the same error.

How can I solve this problem and get the samples running?

My Model & Components Version:
Model: Nvidia Jetson AGX Xavier

  • Jetpack 4.3 [L4T 32.3.1]
  • CUDA GPU architecture 7.2
  • CUDA 10.0.326
  • cuDNN 7.6.3.28-1+cuda10.0
  • TensorRT 6.0.1.10-1+cuda10.0
  • Visionworks 1.6.0.500n
  • OpenCV 4.1.1 compiled CUDA: Yes
  • DeepStream 4.0

Tried to find libnvinfer

dpkg -l | grep libnvinfer

Results

ii  libnvinfer-bin                                6.0.1-1+cuda10.0                                arm64        TensorRT binaries
ii  libnvinfer-dev                                6.0.1-1+cuda10.0                                arm64        TensorRT development libraries and headers
ii  libnvinfer-doc                                6.0.1-1+cuda10.0                                all          TensorRT documentation
ii  libnvinfer-plugin-dev                         6.0.1-1+cuda10.0                                arm64        TensorRT plugin libraries
ii  libnvinfer-plugin6                            6.0.1-1+cuda10.0                                arm64        TensorRT plugin libraries
ii  libnvinfer-samples                            6.0.1-1+cuda10.0                                all          TensorRT samples
ii  libnvinfer6                                   6.0.1-1+cuda10.0                                arm64        TensorRT runtime libraries
ii  python-libnvinfer                             6.0.1-1+cuda10.0                                arm64        Python bindings for TensorRT
ii  python-libnvinfer-dev                         6.0.1-1+cuda10.0                                arm64        Python development package for TensorRT
ii  python3-libnvinfer                            6.0.1-1+cuda10.0                                arm64        Python 3 bindings for TensorRT
ii  python3-libnvinfer-dev                        6.0.1-1+cuda10.0                                arm64        Python 3 development package for TensorRT

Thank you.

Solved by roll back to JetPack 4.2.3 with TensorRT 5.1.6.1

Seems like TensorRT 6.0.1 is not compatible with sample configs

1 Like