Deepstream-app error on first run

• Hardware Platform (Jetson Nano 4GB)
• DeepStream Version = 5.1
• JetPack Version = 4.6 (fresh jetpack 4.6)
• TensorRT Version=8.0.1
Installed Using the DeepStream tar package.
Then I run deepstream-app on the terminal then give me this error:

deepstream-app: error while loading shared libraries: libnvinfer.so.7: cannot open shared object file: No such file or directory

Then I tried to re install the deepstream Using the DeepStream Debian package and it also gave me an error:

$ sudo apt-get install ./deepstream-5.1_5.1.0-1_arm64.deb 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'deepstream-5.1' instead of './deepstream-5.1_5.1.0-1_arm64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 deepstream-5.1 : Depends: libnvinfer7 (>= 7.1.0) but it is not installable
                  Depends: libnvparsers7 (>= 7.1.0) but it is not installable
                  Depends: libnvonnxparsers7 (>= 7.1.0) but it is not installable
                  Depends: libnvinfer-plugin7 (>= 7.1.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

any workaround to fix this? Or should i install DP5.0?

1 Like

You installed the wrong JetPack version. Please refer to Quickstart Guide — DeepStream 5.1 Release documentation

So, when the new deepstream version (for JP 4.6) will be released?

No exact date. We will announce once it is available.