DeepStream 6.1 docker nvcc command not found

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• Issue Type( questions, new requirements, bugs)

Hey !
ive been trying to install open cv on a deepstream docker , and ran into a problem.
first cmake couldn’t compile, so I ran ’ nvcc --version’
that command was not found either
turns out there is no path /usr/local/cuda/bin
there is /usr/local/cuda that contains:

root@ubuntu:/usr/local/cuda# ll
total 12
drwxr-xr-x 1 root root 4096 Mar 29 2022 ./
drwxr-xr-x 1 root root 4096 Mar 29 2022 …/
lrwxrwxrwx 1 root root 9 Mar 29 2022 cuda-11.4 → cuda-11.4
lrwxrwxrwx 1 root root 29 Nov 12 2021 include → targets/aarch64-linux/include/
lrwxrwxrwx 1 root root 25 Nov 15 2021 lib64 → targets/aarch64-linux/lib/
drwxr-xr-x 1 root root 4096 Mar 29 2022 targets/

Which docker container are you using? Only the container with postfix as “-devel” contains the development environment, difference of each containers can be found here: Docker Containers — DeepStream 6.2 Release documentation (

Hey as I pointed ,
I’m using the jetson docker
at deepstream 6.0 there was nvcc but seems like in deepstream 6.1 something changed
I tried all these images :

any pointers?

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

To make the docker image smaller, some binaries are not included.

You may share the host binary. E.G.
sudo docker run -it --rm --net=host --runtime nvidia -e DISPLAY=$DISPLAY -w /opt/nvidia/deepstream/deepstream-6.2 -v /tmp/.X11-unix/:/tmp/.X11-unix -v /usr/local/cuda/bin:/usr/local/cuda/bin

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.