Deepstream-app not saving multi video from multi-stream

• DeepStream Version: 5.1-21.02-devel

I’m using the following config file source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt with 4 rtsp sources and have separate sinks to save distinct outputs (mp4).

My config file:
config.txt (6.1 KB)

enable-perf-measurement=1
perf-measurement-interval-sec=5
#gie-kitti-output-dir=streamscl

[tiled-display]
enable=0
rows=2
columns=2
width=1280
height=720
gpu-id=0
#(0): nvbuf-mem-default - Default memory allocated, specific to particular platform
#(1): nvbuf-mem-cuda-pinned - Allocate Pinned/Host cuda memory applicable for Tesla
#(2): nvbuf-mem-cuda-device - Allocate Device cuda memory applicable for Tesla
#(3): nvbuf-mem-cuda-unified - Allocate Unified cuda memory applicable for Tesla
#(4): nvbuf-mem-surface-array - Allocate Surface Array memory, applicable for Jetson
nvbuf-memory-type=0

[source0]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI 4=RTSP
type=3
uri=rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov
num-sources=1
#drop-frame-interval=2
gpu-id=0
cudadec-memtype=0

[source1]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI 4=RTSP
type=3
uri=rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov
num-sources=1
#drop-frame-interval=2
gpu-id=0
cudadec-memtype=0

[source2]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI 4=RTSP
type=3
uri=rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov
num-sources=1
#drop-frame-interval=2
gpu-id=0
cudadec-memtype=0

[source3]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI 4=RTSP
type=3
uri=rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mov
num-sources=1
#drop-frame-interval=2
gpu-id=0
cudadec-memtype=0

[sink0]
enable=1
type=3
#1=mp4 2=mkv
container=1
#1=h264 2=h265
codec=1
#encoder type 0=Hardware 1=Software
enc-type=0
sync=0
#iframeinterval=10
bitrate=4000000
#H264 Profile - 0=Baseline 2=Main 4=High
#H265 Profile - 0=Main 1=Main10
profile=0
output-file=/opt/nvidia/deepstream/deepstream-5.1/sources/python/sample_apps/deepstream-app/out1.mp4
source-id=0

[sink1]
enable=1
type=3
#1=mp4 2=mkv
container=1
#1=h264 2=h265
codec=1
#encoder type 0=Hardware 1=Software
enc-type=0
sync=0
#iframeinterval=10
bitrate=4000000
#H264 Profile - 0=Baseline 2=Main 4=High
#H265 Profile - 0=Main 1=Main10
profile=0
output-file=/opt/nvidia/deepstream/deepstream-5.1/sources/python/sample_apps/deepstream-app/out2.mp4
source-id=1

[sink2]
enable=1
type=3
#1=mp4 2=mkv
container=1
#1=h264 2=h265
codec=1
#encoder type 0=Hardware 1=Software
enc-type=0
sync=0
#iframeinterval=10
bitrate=4000000
#H264 Profile - 0=Baseline 2=Main 4=High
#H265 Profile - 0=Main 1=Main10
profile=0
output-file=/opt/nvidia/deepstream/deepstream-5.1/sources/python/sample_apps/deepstream-app/out3.mp4
source-id=2

[sink3]
enable=1
type=3
#1=mp4 2=mkv
container=1
#1=h264 2=h265
codec=1
#encoder type 0=Hardware 1=Software
enc-type=0
sync=0
#iframeinterval=10
bitrate=4000000
#H264 Profile - 0=Baseline 2=Main 4=High
#H265 Profile - 0=Main 1=Main10
profile=0
output-file=/opt/nvidia/deepstream/deepstream-5.1/sources/python/sample_apps/deepstream-app/out4.mp4
source-id=3

[osd]
enable=1
gpu-id=0
border-width=1
text-size=15
text-color=1;1;1;1;
text-bg-color=0.3;0.3;0.3;1
font=Serif
show-clock=0
clock-x-offset=800
clock-y-offset=820
clock-text-size=12
clock-color=1;0;0;0
nvbuf-memory-type=0

[streammux]
gpu-id=0
live-source=0
batch-size=4
batched-push-timeout=40000
width=1920
height=1080
enable-padding=0
nvbuf-memory-type=0

[primary-gie]
enable=1
gpu-id=0
model-engine-file=…/…/models/Primary_Detector/resnet10.caffemodel_b4_gpu0_int8.engine
batch-size=2
#Required by the app for OSD, not a plugin property
bbox-border-color0=1;0;0;1
bbox-border-color1=0;1;1;1
bbox-border-color2=0;0;1;1
bbox-border-color3=0;1;0;1
interval=0
gie-unique-id=1
nvbuf-memory-type=0
config-file=config_infer_primary.txt

[tracker]
enable=1

tracker-width=640
tracker-height=384
#ll-lib-file=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_mot_iou.so
#ll-lib-file=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_nvdcf.so
ll-lib-file=/opt/nvidia/deepstream/deepstream-5.1/lib/libnvds_mot_klt.so
#ll-config-file required for DCF/IOU only
ll-config-file=ll-config-file=/opt/nvidia/deepstream/deepstream-5.1/samples/configs/deepstream-app/tracker_config.yml
#ll-config-file=iou_config.txt
gpu-id=0
#enable-batch-process applicable to DCF only
enable-batch-process=1

[tests]
file-loop=0

I’ve trouble in running.
Please provide definitely applicable to your config.

Hi,

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)

• Hardware Platform (Jetson / GPU): GTX 1050
• DeepStream Version: 5.1
• TensorRT Version: 7.2
• NVIDIA GPU Driver Version (valid for GPU only): Driver=460 - Cuda=11.1

Please suggest any solution!

Geforce 1050 support max 3 concurrent sessions for NVENC.

BOARD FAMILY CHIP NVENC Desktop/ # OF # OF Total Max # of H.264 H.264 H.264 H.265 H.265 H.265 H.265 HEVC HEVC
Generation Mobile CHIPS NVENC # of concurrent (AVCHD) (AVCHD) (AVCHD) (HEVC) (HEVC) (HEVC) (HEVC) 10-bit B Frame
/CHIP NVENC sessions YUV 4:2:0 YUV 4:4:4 Lossless 4K YUV 4:2:0 4K YUV 4:4:4 4K Lossless 8k support support
GeForce GTX 1050 / 1050 Ti Pascal GP107 6th Gen D/M 1 1 1 3 YES YES YES YES YES YES YES YES NO
1 Like

Thanks for your suggestion so much. I forget to check that.

I have a query. How can I save more than 3 sources ?

You can use software encoder from above 3 sources. or you can just output the sources tiled into one file.

Thanks your response. I saved 4 individual files from 4 inputs as follows each sink config:

[sink0]
enable=1
type=3
#1=mp4 2=mkv
container=1
#1=h264 2=h265
codec=1
#encoder type 0=Hardware 1=Software
enc-type=1
sync=0
#iframeinterval=10
bitrate=4000000
#H264 Profile - 0=Baseline 2=Main 4=High
#H265 Profile - 0=Main 1=Main10
profile=0
output-file=/opt/nvidia/deepstream/deepstream-5.1/sources/python/sample_apps/deepstream-app/out1.mp4
source-id=0

I reached 4 outputs mp4 but my host PC can’t show up with " This file contains no playable streams" error .
Please suggest any solution.

I solved by replacing output format mp4 with mkv container=2

Glad to know.