Deepstream installation on RTX 3050 Ti

NVIDIA driver 535.104.12 is not supported on RTX 3050ti, which is required for ds6.4, is there other deepstream version i can install, whats the other driver version i can install.

You can try version 535.xxx.xxx of the driver. Generally speaking, it can work.

Minor versions usually do not have a significant impact.

When i searched drivers for RTX 3090 Ti ,I can only find Game ready drivers, and studio driver 551.86 ,how to get 535.x?

google can help you solve this problem

Getting these kind of error in log file while installaling the driver, in building kernal module ,did X server off and updated to gcc 12

/tmp/selfgz26751/NVIDIA-Linux-x86_64-535.54.03/kernel/common/inc/nv-mm.h:88:16: error: too many arguments to function ‘get_user_pages’
88 | return get_user_pages(current, current->mm, start, nr_pages, write,

What is your system version? This problem is usually caused by a mismatch between the driver and kernel versions.
DS-6.4 requires ubuntu 22.04, you can use this OS

Ubuntu 22.04.4 LTS, now i installed 535 driver from software and updates section of ubuntu, but nvidia -smi not working.
Also when i manually installed 535.146.xx, nvidia-smi was not working
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

You may refer to the guide from ubuntu. I think you should restart the os, then uninstall and install the gpu driver again.

https://ubuntu.com/server/docs/nvidia-drivers-installation