DeepStream on Jetson TX2 failures (Solved)

Hello,

I am trying out DeepStream on the Jetson TX2. My installation seems to have gone fine. However, when running samples, (as per the instructions in the README), I encountered segfaults/core dumps.

My configuration:
I’m using JetPack 3.3 on Jetson TX2, and the DeepStream 1.5 pre-release for Jetson.

Has this combination been tested? Or do I need to downgrade to JetPack 3.2?

Thanks.

Hi,

You can’t run DS-1.5 on JetPack-3.3 (BSP l4t-r28.2.1 for TX2).

Basically, DeepStream for Jetson 1.5 should run on JetPack-3.2/R28.2. You can check software requires from README. Thanks.

Thank you for the clarification.

It would be nice for the Jetpack releases to be backward compatible. i.e. anything that works with Jetpack 3.2 must also work when Jetpack is upgraded to Jetpack 3.3.

Otherwise, we will have some software A that works with only Jetpack 3.2, some other software B that works with only Jetpack 3.3. If we want to use both software A and software B on our Jetson, how do we achieve this? i.e. which Jetpack version do we install?

Instead, if backward compatibility were maintained, we can always install the latest version of Jetpack.

Thanks.

Hi,

Could you try Jetpack 3.2.1 with DeepStream 1.5? We have tried and it’s working.

The primary updates from Jetpack 3.2 to Jetpack 3.3 are listed below.
BSP: r28.2 -> r28.2.1 (for TX2)
cuDNN: 7.0.5 -> 7.1.5
TensorRT: from 3.0 -> 4.0

And, the primary updates from Jetpack 3.2 to Jetpack 3.2.1 is only BSP(r28.2->28.2.1 for TX2).

Thank you, Fred.
I have installed JetPack 3.2.1 now, and tried it out with DeepStream 1.5.
I am glad to report that the demo application is working.

Thanks again for your help. Please do pass on my suggestion of maintaining backward compatibility, to the development team within NVIDIA.