Deepstream SDK-3 Error

:~/Downloads/DeepStream_Release/samples$ deepstream-app -c /home/nvidia/Deepstream-3/DeepStream_Release/samples/configs/deepstream-app/source30_720p_dec_infer-resnet_tiled_display_int8.txt
** ERROR: <parse_app:1123>: pipeline-frame-width and pipeline-frame-height must be set
if flow-original-resolution is disabled
** ERROR: <parse_app:1136>: parse_app failed
** ERROR: <parse_config_file:1320>: parse_config_file failed
** ERROR: main:456: Failed to parse config file ‘/home/nvidia/Deepstream-3/DeepStream_Release/samples/configs/deepstream-app/source30_720p_dec_infer-resnet_tiled_display_int8.txt’
Quitting

(deepstream-app:95226): GStreamer-CRITICAL **: gst_element_get_static_pad: assertion ‘GST_IS_ELEMENT (element)’ failed

(deepstream-app:95226): GStreamer-CRITICAL **: gst_pad_send_event: assertion ‘GST_IS_PAD (pad)’ failed

(deepstream-app:95226): GStreamer-CRITICAL **: gst_element_set_state: assertion ‘GST_IS_ELEMENT (element)’ failed

(deepstream-app:95226): GStreamer-CRITICAL **: gst_element_get_bus: assertion ‘GST_IS_ELEMENT (element)’ failed

(deepstream-app:95226): GStreamer-CRITICAL **: gst_bus_remove_watch: assertion ‘GST_IS_BUS (bus)’ failed

(deepstream-app:95226): GStreamer-CRITICAL **: gst_object_unref: assertion ‘object != NULL’ failed

(deepstream-app:95226): GStreamer-CRITICAL **: gst_object_unref: assertion ‘object != NULL’ failed

Close solved

How?

I am having similar issue:
$ deepstream-app -c configs/deepstream-app/config_infer_primary.txt

(deepstream-app:3270): GStreamer-CRITICAL **: 17:39:48.265: gst_element_get_static_pad: assertion ‘GST_IS_ELEMENT (element)’ failed
Segmentation fault (core dumped)

How to solve this.

Same problem here:

deepstream-app -c sources/objectDetector_Yolo/config_infer_primary_yoloV3.txt -i samples/streams/sample_1080p_h265.mp4

whether I give an input or not or whether it’s a video oder image file doesn’t make a difference, the error is the same

(deepstream-app:5411): GStreamer-CRITICAL **: 15:13:37.600: gst_element_get_static_pad: assertion 'GST_IS_ELEMENT (element)' failed

Having the same error as above, how to solve them please can someone help.

Please try with the latest release DeepStream SDK 4.0.1 to see if still can reproduce the error.
If yes, please file a new topic.

Thanks

I am seeing somewhat similar, mine is latest sdk
~/deepstream_sdk_v4.0.1_x86_64/sources/apps/sample_apps/deepstream-app$ ./deepstream-app -c /home/ubuntu/deepstream_sdk_v4.0.1_x86_64/samples/configs/deepstream-app/source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt
Creating LL OSD context new
gstnvtracker: Loading low-level lib at /opt/nvidia/deepstream/deepstream-4.0/lib/libnvds_mot_klt.so
gstnvtracker: Optional NvMOT_RemoveStreams not implemented
gstnvtracker: Batch processing is OFF

Runtime commands:
h: Print this help
q: Quit

    p: Pause
    r: Resume

NOTE: To expand a source in the 2D tiled display and view object details, left-click on the source.
To go back to the tiled display, right-click anywhere on the window.

**PERF: FPS 0 (Avg) FPS 1 (Avg) FPS 2 (Avg) FPS 3 (Avg)
**PERF: 0.00 (0.00) 0.00 (0.00) 0.00 (0.00) 0.00 (0.00)
** INFO: <bus_callback:189>: Pipeline ready

Creating LL OSD context new
KLT Tracker Init
KLT Tracker Init
KLT Tracker Init
KLT Tracker Init
cuGraphicsGLRegisterBuffer failed with error(999) gst_eglglessink_cuda_init texture = 1
** INFO: <bus_callback:175>: Pipeline running

**PERF: 71.74 (71.74) 71.74 (71.74) 71.74 (71.74) 71.74 (71.74)
**PERF: 0.00 (71.74) 0.00 (71.74) 0.00 (71.74) 0.00 (71.74)
ERROR from secondary_gie_bin_queue: Internal data stream error.
Debug info: gstqueue.c(988): gst_queue_handle_sink_event (): /GstPipeline:pipeline/GstBin:secondary_gie_bin/GstQueue:secondary_gie_bin_queue:
streaming stopped, reason not-negotiated (-4)
Quitting
ERROR from sink_bin_queue: Internal data stream error.
Debug info: gstqueue.c(988): gst_queue_handle_sink_event (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstQueue:sink_bin_queue:
streaming stopped, reason not-negotiated (-4)
App run failed

Hi gayatri,
Is your device Tesla P4? Do you make any modification to source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt?

Hi Dane , I am using tesla v100. I see a blank window with EglSink and fails with the above error. I connect using xming x11 port forwarding using putty, but after reading forum related to this, I enabled fakesink, and the job completes. I tried long using x11, and I dont know other ways that might work. Is xming one of the correct way to connect to view the output in the UI?

Hi,
V110 is headless GPU.
You can stream as RTSP out and view it in VLC player or encode into a file. Please check
https://docs.nvidia.com/metropolis/deepstream/dev-guide/index.html#page/DeepStream_Development_Guide%2Fdeepstream_app_config.3.2.html%23wwpID0ENHA

A sample config of ‘Encode + RTSP streaming’
https://devtalk.nvidia.com/default/topic/1061580/deepstream-sdk/how-do-i-view-the-output-through-the-rtsp-/post/5375714/#5375714

Thanks , I can a decode it a file for now. Sure will look into RTSP streaming.
What about T4 and P4 are they headless too?

Hi Dane, I can stream the output in VLC player, but the output is shaky. I am still in the example phase.

Hi,
Does the issue happen if you set to ‘Encode + File Save’? Probably the network is unstable, triggering unstable RTSP?

Hi Dane,
Yes the quality is good when I use ‘Encode + File Save’ . Sure, the network may not be that good…