Dell XPS 15 Nvidia 1650 GPU - Horrible Screen Tearing

Hi all,

I have tried every single fix I could find online, but none of them has made any perceivable difference. I’m getting incredibly frustrated, as I just spent quite a bit on this laptop and it has been a non-stop battle to get things running smoothly (and I love tinkering with Linux).

Edit: (clarification of the issue): The laptop presents horrible screen tearing while moving windows, browser scrolling (Firefox + Chrome), video playback (VLC / in-browser), and all animations. I.e., anything that requires the graphics card.

The laptop is currently running Ubuntu 19.10 with the Proprietary Nvidia 435 drivers. Within nvidia-settings, I have tried changing the mode to ‘use only Nvidia GPU’ (no change). I have also tried switching to the Nouveau open-source drivers, which did fix the issue - but only because it switched the laptop to run off the integrated Intel chipset rather than the Nvidia GPU.

Some things I have tried:

  • Installing this post-install script:
  • ...then troubleshooting the screen tearing via his suggestions:
  • Switching to the Proprietary 430 drivers
  • Switching to the Nouveau drivers (this forced the laptop into the Intel chipset)
  • Adjusting all nvidia-settings I could find (use only Nvidia GPU, etc.)

My questions:

I have read that the Nouveau drivers are supposed to ‘work’ to fix screen-tearing in Ubuntu 19.10. When I switch to those open source drivers, it immediately switches to the Intel chipset. Is there a way to enable the Nvidia GPU after switching to the Nouveau drivers? I’m at the point where I’m willing to punt battery life and just run the Nvidia GPU non-stop if it will fix the horrible screen tearing. Most of the time I have the laptop plugged in, anyways.

Is there something I am missing to 100% fix screen tearing using the Proprietary Nvidia 435 drivers? I can’t be the only one having this issue.

From my research, it seems like I need to somehow enable the Nvidia “VSync” for the card? Any ideas on how to do that?

Thank you so much for your help!

Side note: for anyone trying to fix the Dell XPS 15 7590 brightness slider in Ubuntu for the OLED screen, I was never able to get it to work. However, I hacked together a workaround using .bashrc and xrandr commands.

I included these commands below, in case it helps anyone. The duplicate commands were intentional - when the computer switches to the Intel chipset, the xrandr variable changes.

I was sick of re-writing the commands when I was troubleshooting the screen tearing above (and the screen is blindingly bright at full blast), so I just added both. You’ll get a small error message when entering “6” (or whatever brightness setting) into your terminal, but it still works fine.

.bashrc code to adjust OLED brightness using numerical terminal commands:

alias 1="xrandr --output eDP-1 --brightness 0.1; xrandr --output eDP-1-1 --brightness 0.1"
alias 2="xrandr --output eDP-1 --brightness 0.2; xrandr --output eDP-1-1 --brightness 0.2"
alias 3="xrandr --output eDP-1 --brightness 0.3; xrandr --output eDP-1-1 --brightness 0.3"
alias 3="xrandr --output eDP-1 --brightness 0.3; xrandr --output eDP-1-1 --brightness 0.3"
alias 4="xrandr --output eDP-1 --brightness 0.4; xrandr --output eDP-1-1 --brightness 0.4"
alias 5="xrandr --output eDP-1 --brightness 0.5; xrandr --output eDP-1-1 --brightness 0.5"
alias 6="xrandr --output eDP-1 --brightness 0.6; xrandr --output eDP-1-1 --brightness 0.6"
alias 7="xrandr --output eDP-1 --brightness 0.7; xrandr --output eDP-1-1 --brightness 0.7"
alias 8="xrandr --output eDP-1 --brightness 0.8; xrandr --output eDP-1-1 --brightness 0.8"
alias 9="xrandr --output eDP-1 --brightness 0.9; xrandr --output eDP-1-1 --brightness 0.9"
alias 10="xrandr --output eDP-1 --brightness 1.0; xrandr --output eDP-1-1 --brightness 1.0"