must be the only 1 around with desktop problem

all i see around in this place,are ppl with laptops and notebooks,but i must be the only 1 around that use desktop pc with linux,well,the problem that all have is tearing,just an intel scpu and just 1 nvidia card (gtx 750 ti),i am using maui 2 linux that runs on 4.4.0 kernel and i have installed the 370 nvidia drivers,i am a noob,but i actually don’t find anything around to solve the tearing for a desktop pc,that don’t face the optimus thing,i only have 1 gpu,not 2,so ? is there anything for me ?

I am on a desktop too so your observation is not correct.
I am on OpenSuse on kernel 4.9.0 rc-1 higher kernels like 4.9.0 rc-2 or 4.9.0 rc-3 do not work for me with my nvidia gtx 750 TI but my old Intel 2000 does not have any peoblems with these kernels.

I guess you can solve your tearing problem by uninstalling driver 370 which is beta and installing driver 367 which is stable.

well, i started with the 361,no fix, got the 364,same thing, 367 was not any better, reading texts in Firefox is a real pain for the eyes, i can see clearly the wave of the refresh, actually i see 2 different lines about at the same half of the half, watching movies is a pain too, i see an upper line unsynced, i’ve tryed different configs, with vsync on and off, that in the Nvidia settings and in the plasma settings (i’m talking about the kde plasma) and nothing, no changes at all and as far as i can tell, the prime and bumblebee were made for the laptops that uses the 2 gpus, i am happy to see i’m not the only 1 around using desktop pc :)
i guess that the problem will be solved when xorg 1.19 will come out in combination with the new kernel 4.9 and maybe a new Nvidia driver
i really wish to get rid of that tearing, at least in Firefox, my eyes get tired really fast coz of it

I’m guessing you are using KDE.

The last time I used KDE, you had to set certain environment variables to make it not disable vsync when using the NVIDIA drivers. Looking through old files here, it seems I first used these environment variables:


Additionally, the nvidia device section of the Xorg config had this here added:

Option "TripleBuffer" "False"

You should perhaps look for a guide for the distro you use that’s explaining how to use the proprietary nvidia drivers, then look through its steps very closely. It perhaps mentions something about this stuff here.

ty, i will try to see where to fit that, yes, i use kde, i did asked in the forum but i only got some links with gnome commands, i really have no idea the translation in kde and prolly not even same thing, i am a noob into Linux and besides it were talking about bumblebee and prime, don’t think it will help me