Screen Tearing after upgrade to 970

The desktop display is fine, watching videos is okay, but when I load up games I get constant screen tearing. I’m running Ubuntu 14.04 64-bit on an Intel i5-2500k 3.30GHz, 16GB RAM, 2TB Barracuda 7200 RPM, w/ dual monitors @1080p Samsung SyncMaster PX2370.

I recently upgraded my video card from a Nvidia 560Ti to a Nvidia 970. As soon as I loaded up my first game I noticed screen tearing. I tried enabling and disabling v-sync but it did not help. Actually v-sync can make it worse for some games! see below

For the 560Ti I had installed the 346.47 binaries from Nvidia’s site. When v-sync did not work, I upgraded my driver to 352.21. I purged the older driver and installed the new binary. However, DKMS would not integrate. If I run dkms status it shows driver version 331.113, but I have not been able to figure out how to remove it as of yet. But that is not what I am concerned about.

What I need help with it figuring out why my new card has such horrible screen tearing. It was not a problem before. I did not change graphics settings in my games. It seems like this new card either has a hardware or driver issue, but I’m not sure.

Any suggestions on how I might fix this problem?

Games Tested:

Wasteland 2 - Tearing when moving overhead view
Cities: Skylines - V-sync DISABLED removes tearing
The Fall - Tear in middle of the screen anytime you walk
Dungeons 2 - Slight tearing when moving the view around
The Talos Principle - V-sync ENABLED removes tearing
Torchlight II - No tearing
Team Fortress 2 - Slight tearing, some ghosting
Borderlands 2 - V-sync DISABLED removes tearing
nvidia-bug-report.log.gz (101 KB)

Finally found the answer here: https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1278012/comments/12

Open a terminal and type:

gksudo gedit /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf

Then add the -bs option to your lightdm config

[SeatDefaults]
# Dump core
xserver-command=X -bs -core

Disabling the backing store might not do it in every case, you may need to disable unredirecting fullscreen windows: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1307144

This was fixed at one point and then rebroken. Ubuntu’s compiz stack isn’t super well maintained these days…