Disable big cores?

Hi all, Hunting some bugs and I’d like to run only on LITTLE cores as we’re wondering if Out-of-Order execution is causing havoc for us. LITTLE cores are supposed to be in-order and big cores are supposed to do OoO.

So, can I disable the switch from LITTLE to big?

http://elinux.org/Jetson/Performance was the best I could find, but that’s for TK1. There’s also a document on the elinux-site for TX1 but it only describes how to make things run as FAST as possible :-)

Cheers,
Pekka.

Jetson TX1 has the four Cortex-A57 cores accessible only. It isn’t possible to change the active cluster to an A9 like with TK1 or to an A53.

If you’d like to control individual A57 cores, you can do that by echoing 0 or 1 (as sudo or su) to the files in /sys/devices/system/cpu/cpu*/online

FYI, CPU0 does not have an online file:

cat /sys/devices/system/cpu/cpu0/online
cat: /sys/devices/system/cpu/cpu0/online: No such file or directory

ls /sys/devices/system/cpu/cpu0/
cpufreq  cpuidle  cpuquiet  power  subsystem  topology  uevent

CPUs one through three do.

Thanks dusty and trap,

as far as my understanding goes, /sys/devices/system/cpu/cpu1-3/online turns the whole core on or off. I.e if I echo 0 to CPUs 1-3, I see only one core (cpu0) in userland. And like Trap mentioned, cpu0 can’t be put offline.

So the question still stands, can I somehow turn off the hop from LITTLE execution to big?

Cheers,
Pekka.

Jetson TX1 includes the four A57 cores only. There isn’t changing of cluster.

Ah, pardon my tardiness, I was under the illusion that there indeed is a big.LITTLE configuration in TX1 and pigheadedly decided not to be intelligent and research your answer thoroughly :-)

Thanks dusty!