Forcing execution on A57 cluster

Is there any way to disable the A53 cluster and force execution on the A57 cluster, to ensure maximal CPU performance? We’ve previously seen disappointing CPU performance on the TX1 compared to TK1 (http://openbenchmarking.org/result/1512084-HA-6977069441) and we’re worried that the reduction in max frequency with L4T 23.2 could make this even worse.

A previous Dusty post (https://devtalk.nvidia.com/default/topic/894945/jetson-tx1/jetson-tx1/post/4734485/#4734485) suggests that this should be possible, but my TX1 doesn’t have a /sys/kernel/cluster, even after I’ve just upgraded to L4T 23.2.

Thanks

I don’t know what config option is required, but that’s probably a kernel configuration option requirement for making the cluster files show up in /sys (and defaults for JTX1 versus JTK1 config would differ…I think there is some cross-over of information between TK1 and TX1 which would be true only if kernel configs are changed).

As long as all CPUs are online the faster cluster should always be active. You should see “0-3” from:

cat /sys/devices/system/cpu/online

Keep in mind that the next L4T release will have some 32/64-bit changes; as the current L4T is 64-bit kernel space but 32-bit user space, this could be a dramatic change. I can’t say what 32-bit mode is doing to slow things down, but unless your benchmark runs entirely in kernel space you can’t (yet) really measure what the CPUs are capable of.

I believe the A53 cluster on the Jetson TX1 should be non-functional, so this shouldn’t be a concern.