Disable integrated GPU on lenovo laptop and Fedora 39

Hi all,

I am having a lenovo laptop with a Geforce RTX 4050 GPU and a freshly installed Fedora 39.

I have

glxinfo | grep -e OpenGL.vendor -e OpenGL.renderer
OpenGL vendor string: AMD
OpenGL renderer string: AMD Radeon Graphics (radeonsi, rembrandt, LLVM 17.0.6, DRM 3.57, 6.7.10-200.fc39.x86_64)

and

lspci -n -n -k | grep -A 2 -e VGA -e 3D

pcilib: Error reading /sys/bus/pci/devices/0000:00:08.3/label: Operation not permitted
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation AD107M [GeForce RTX 4050 Max-Q / Mobile] [10de:28a1] (rev a1)
	Subsystem: Lenovo Device [17aa:3af8]
	Kernel driver in use: nvidia
--
05:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Rembrandt [Radeon 680M] [1002:1681] (rev 0b)
	Subsystem: Lenovo Device [17aa:3af8]
	Kernel driver in use: amdgpu

I have tried to disable the amdgpu in bios but I do no have the option to edit the Integrated Graphics.
Moreover, in bios, the shown GPU is the NVIDIA one.

I also get

lsmod | grep -iE 'noveau|nvidia'
nvidia_drm            126976  5
nvidia_modeset       1605632  2 nvidia_drm
nvidia_uvm           6651904  0
nvidia              60370944  43 nvidia_uvm,nvidia_modeset
video                  77824  3 amdgpu,ideapad_laptop,nvidia_modeset

Can I get any help please to disable amdgpu and make my system use the NVIDIA one?
Thank you!

You do not want to disable the integrated GPU. That is what the laptop display is attached to.
See this for examples of how to use the Nvidia GPU: Howto/Optimus - RPM Fusion

Thanks