Disabling bios screen

We would like to disable the bios setup screen or an option to show the screen on the Orin NX 16gb.

Is there any way to do so

Hi DavidJubaan,

What’s the carrier board for your Orin NX module? Is it p3509 carrier board or your custom board?

What do you mean the “bios setup screen”? (any screenshot for reference?)
Is that the 5s countdown to enter UEFI boot menu?

Yes for both - we are using p3509 and yes, the countdown to enter the UEFI boot menu. We don’t care to show the blob image (we have changed it to our own logo), but would like to avoid the customer entering the boot menu or the bios setup by mistake.

Thank you for answering

You could refer to the Q: There is a wait in UEFI stage. How to disable it to accelerate system booting? in this FAQ.

Thank you, still, after changing this param do we have to recompile the boot loader and re-flash?

Isn’t there an option to manually enable or disable this screen?


If you just want to configure current device, you could set autoboot time in UEFI boot menu.
Boot Maintenance Manager → Auto Boot Time-out → Change value to 0 → Press F10 to Save

If you have multiple devices and will release the image, please refer to the previous guide to set it to zero and recompile the uefi_jetson.bin.

Thank you got it. Excellent!!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.