DisplayPort not working

HDMI output works fine, but when I switch to DP I get no output. Any setting that needs to be adjusted?

1 Like

It should work. Could you share the dmesg?

Hi dvltav,

Which image are you using?
The DP is works on JetPack-4.2/Nano.

Are you using pure image from jetpack?

I’m using the standard image from the getting stared page.

I have tried another Jetson Nano board, same issue.

I’ll try different monitor.

I’ve tried getting dmesg, but the board seems to just down shortly after power up when DP is plugged in. I’m using iPad 10w power adapter.

Hi dvltav,

Could you try others 5V power adapter?
We’re using this one: https://www.adafruit.com/product/1995

I am having similar issue where HDMI works fine, but plugging in a DP monitor gives only a line of bunch of small white artifacts against black screen. I see mouse cursor on 3 lines with artifacts. I tested monitor on a laptop and DP works fine. I am using 5v 2.5 amp power adapter similar to the Adafruit adapter. I have a mouse, keyboard and recommended Edimax wifi dongle plugged into USB.

I am now using a 5v 10A power adapter. I can get HDMI to work fine, but no luck still on getting DisplayPort to work. Any ideas?

Could you share the boot kernel log with us?
Please connect only the DP monitor, boot up and use command dmesg

Hi Everyone,

I have a Jetson Tx2 board.
I am totally new to this field and had some questions.
The datasheet provided by Nvidia says there are

  1. 2 CPU Clusters - Arm(quad core) and Denver(dual core)

Does this mean the GPU (CUDA Cores) are actually the Denver cores. Since, GPU is a cluster of CPUs.
I am confused. I would appreciate some clarity.

Thank you so much

I get no video on the DP port, so I would be unable to bring up a console to type dmesg. Would the log entries still be there if I shutdown and hook to HDMI and then did dmesg? Sorry still new to the Linux world.

A possibility is that if you go to a text console it might work…try CTRL-ALT-F2.

Hi dhwanimehta, the ARM A57 and Denver are CPU cores (so there are 6 CPU cores total). The GPU is different than CPU, there are 256 CUDA Pascal GPU cores in TX2. For further questions about TX2, please direct them to the Jetson TX2 forum.

I tried a different monitor that is DP 1.2 compliant and DP is working fine on the Nano. The other monitor I had issues with was DP 1.0 or 1.1, not sure. Glad that DP is working. I am using the 5v 10A power brick.

Good to know it works now, thanks for the feedback.

I also had luck getting a DisplayPort to VGA adapter working. It allowed me to use an old portable 10" VGA monitor I had laying about.

Just report, the DP works fine with a 5V2.5A power for nano

The dp isn’t working for me either. I’m using a dp-HDMI cable. The monitors itself is HDMI. Could thatbe the problem?

1 Like

Could you try different cable? or at least dump the kernel log for us.

I have tried several cords, monitors and configurations. Just like My DELL PC computers the Display Port does not work. Why do they even bother putting such a connection on devices? It would be better to skip the Display Port option and just put a VGA port on the device. After all a VGA port works EVERY TIME