DLSS 3 Frame generation Crashing in UE 5.3 in VR (4080 super) driver: 552.12

Does anybody knows the answer for this crash
DLSS 3 Frame generation Crashing in UE 5.3 in VR (4080 super) driver: 552.12
PLEASE HELP :-)

LoginId:0b795741483c310e40e2a18174b56224
EpicAccountId:f97ce30e978547c89799ed9222530176

Assertion failed: (TargetTexture->GetName() == L"BufferedRT") || (TargetTexture->GetName() == L"BackbufferReference") || (TargetTexture->GetName() == L"FD3D11Viewport::GetSwapChainSurface") || (5 == 4) || ((5 == 5 && 3 < 1)) [File:C:\BuildAgent\work\61e303c4da3d085b_stage\plugin\Plugins\Streamline\HostProject\Plugins\Streamline\Source\StreamlineCore\Private\StreamlineViewExtension.cpp] [Line: 285]

UnrealEditor_StreamlineCore!FStreamlineViewExtension::PostProcessPassAtEnd_RenderThread() [C:\BuildAgent\work\61e303c4da3d085b_stage\plugin\Plugins\Streamline\HostProject\Plugins\Streamline\Source\StreamlineCore\Private\StreamlineViewExtension.cpp:425]
UnrealEditor_StreamlineCore!TBaseRawMethodDelegateInstance<0,FStreamlineViewExtension,FScreenPassTexture __cdecl(FRDGBuilder &,FSceneView const &,FPostProcessMaterialInputs const &),FDefaultDelegateUserPolicy>::Execute() [C:\BuildAgent\work\61e303c4da3d085b\BuildScripts_deps\ue\Engine\Source\Runtime\Core\Public\Delegates\DelegateInstancesImpl.h:518]
UnrealEditor_Renderer
UnrealEditor_Renderer
UnrealEditor_Renderer
UnrealEditor_Renderer
UnrealEditor_Renderer
UnrealEditor_Renderer
UnrealEditor_Renderer
UnrealEditor_Core
UnrealEditor_Core
UnrealEditor_RenderCore
UnrealEditor_RenderCore
UnrealEditor_Core
UnrealEditor_Core
kernel32
ntdll

Same problem on my side, any workarounds or the root causes found yet?

Spec:
rtx 4070
i7-8700k
32gb ram
Quest 3 HMD

Software:
Unreal engine: 5.3.2
Nvidia driver: 552.12

Can be reproduced with the vanila VR template project.

Did’nt found anything yet. Still trying the debug it.

Spec
RTX4080 super
I7-14700
64 gb ram
Quest 3 HMD

UE 5.3.2
Driver 552.22

Hello @peter.pagacs and @stefboule, welcome to the NVIDIA developer forums.

I passed this report on to the engineering team, hopefully they will have some idea regarding this crash.

Thanks.

HI :)
I have the same problem and the same message

I also tried on other projects

Spec:
Quest PRO
RTX 4070
Unreal 5.3.2

thanks for the help

Same here.

Spec:
Varjo Aero
RTX 4090
Unreal 5.3.2

Hello @it.inm and @Benutzer6294, welcome to the NVIDIA developer forums.

First of all, this thread might be interesting for people to check how to address some issues with DLSS and VR in UE.

Regarding Frame Generation the bad news is a detail i had nearly forgotten:

VR is not supported with DLSS framegen mostly since framegen uses a dxgi swapchain to present frames to a window. But VR uses a completely separate runtime to present images to an HMD.

In the thread linked above and some other discussions there have been thoughts about how to workaround this, but natively with our plugin this is not possible.

Which does not mean that we should crash and the crash issue is taken rather seriously and looked into right now.

I hope to get some update soon.

thanks for the answer

I saw the tutorial
DLSS+VR+UE

https://www.youtube.com/watch?v=FYnADj-Ai0U
(yes, at the beginning the title said eu5.3, it was probably changed after the information about the eu5.4 version)

other
https://www.youtube.com/watch?v=nMH6KXjrDHw
(in the project they have nvidia dlss plugin (DLSS, NIS, Streamline, DLSSMoviePipelineSupport))

The author can run VRpreview, for me it shows a message and crash

I also wanted to use dlss (upscale/framegeneration), that’s why I’m looking for an answer.

Same problem for me.
I installed the latest version of the plugin for Unreal, DLSS 3.7, and it crashes. However, I no longer have the installation for version 3.5. Is there a link to download it? Or could a kind soul upload version 3.5 for Unreal 5.3? Thank you for the valuable information and updates on this forum.

Same problem for me. Crashes with VR. I replaced the Steamline Plugin 3.7 with the 3.5 version and it now works.

1 Like

Oh! Interesting! I’ll try that version!
Thanks !!

Hi there @nasahdc and @marc_mordelet and welcome to the NVIDIA developer forums.

I replaced the Steamline Plugin 3.7 with the 3.5 version and it now works.

That is helpful information, I will pass it on.

Thanks!

thank you Markus. could you tell me where i can found a 3.5 install link ? there is no old version in the Download page. thank you.

You will probably need to check out an earlier release of Streamline, based on the latest tag before 2.4.0. That should give you the older DLSS-FG version as well.

Thanks, it solved my problem!

thank you Markus :)