DLSS Unreal Engine 4.27 Ghosting/trailing behind moving objects

We have integrated the latest DLSS plugin into our Unreal Engine 4.27 project to make use of the improvements to Anti-Aliasing and Performance. However during this integration, we have encountered an issue with moving objects leaving behind ghosts/trails.
image

The following settings have been validated:

  • r.DefaultFeature.Antialiasing 2
  • r.TemporalAA.Upscaler 1
  • r.Reflections.Denoiser 2
  • r.BasePassForceOutputsVelocity 1
  • r.NGX.DLSS.DilateMotionVectors 1
  • r.NGX.DLSS.AutoExposure 1

Using the Debug overlay, we noticed that we had yellow colored interior offsets when looking at the jitter offset debug. We realized that the default r.TemporalAASamples 8 was not sufficient, so we changed it to r.TemporalAASamples 16. This did not seem to have an effect on the ghosting/trailing we see.

We have tried different combinations of disabling DilateMotionVectors, AutoExposure, BasePassForceOutputsVelocity.

We have also downloaded and built the NvRTX 4.27.2-4 version of the Unreal Engine from the NvRTX/UnrealEngine Github. We have had no improvement to the ghosting/trailing issue with the custom engine or any of the other settings that were suggested by the documentation provided with the plugin.

Is this a known issue of DLSS for Unreal Engine. Does anyone have any suggestions or workarounds that might work to alleviate the issue?

Thank you,
Travis

Hello @tclements1 and welcome to the NVIDIA developer forums!

It is really unfortunate that you are seeing ghosting in your project with DLSS. To get you started and before the experts chime in, did you see the FAQ for Unreal and DLSS, in particular the question about ghosting? While it is too much to hope that this fixes your problems, it still is worth a shot.

Can you please also find out which version the DLSS DLL has that you installed as part of the plugin?

Thanks!

Hello @MarkusHoHo ,

Yes, I have tried the suggestion that was in the FAQ about using r.BasePassForceOutputsVelocity, this did not solve the issue.

The version of the DLSS DLL is 2.3.11.0, this DLL comes from the latest plugin for UE4.27 provided from the DLSS Nivida Download page, Get Started | NVIDIA Developer

Thank you,
Travis

@MarkusHoHo,

I wanted to add that I sent an email that contains the same information, plus a few videos to nvrtx-support@nvidia as recommended from Epic Employees on Unreal Developer Network, and DLSS-Support@nvidia. These emails were sent around November 1st, 2022, when neither of the emails got any replies, I decided to create this forum post.

Has there been any movement on one of the experts chiming in? This is the primary issue we are experiencing when using DLSS, and is what is keeping us from moving forward with the DLSS implementation.

Thank you,
Travis

Hi again,

Our GTC Fall last week has kept people really busy, so it might take a while for an answer. But now this should pick up again and I will also reach out to engineering again.

Thanks for your patience!

Setting r.NGX.DLSS.DilateMotionVectors to 0 fixed the ghosting for me.

Unfortunately that did not work for me. Ghosting still occurs especially after an actor has stood still for a period of time

Thank you for the suggestion, but it did not fix the issue. Before originally posting on the forum, I had tried different combinations of enabling/disabling the following commands with no improvement to the ghosting/trailing.

  • r.BasePassForceOutputsVelocity 1
  • r.NGX.DLSS.DilateMotionVectors 1
  • r.NGX.DLSS.AutoExposure 1