Driver 319.60 fails to recognize device on Dell Precision M6700

This keeps timing out on me when I put my whole message here. But basically…

I am running Centos 6.4 on a Dell Precision M6700. I have installed the
NVIDIA drivers, version 319.60. I tried the 295.41 version as well and got
the same results. The drivers do not see the graphics device as far as I
can tell.

If I do an nvida-smi, I get the following output:

–cut here–
Mon Nov 4 16:40:14 2013
| NVIDIA-SMI 5.319.60 Driver Version: 319.60 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 Quadro K5000M Off | 0000:01:00.0 Off | N/A |
| N/A 56C P0 N/A / N/A | 9MB / 4095MB | 0% Default |

So far so good. And an lspci gives me:

01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [Quadro K5000M] (rev a1)

Both of which would indicate me that I have a K5000M device in the laptop, for
which the driver seems appropriate. But when I start it up, when startx runs
the screen ripples briefly and the following appears in the x log:

[ 57.043] (II) LoadModule: “glx”
[ 57.082] (II) Loading /usr/lib64/xorg/modules/extensions/
[ 57.888] (II) Module glx: vendor=“NVIDIA Corporation”
[ 57.888] compiled for 4.0.2, module version = 1.0.0
[ 57.888] Module class: X.Org Server Extension
[ 57.888] (II) NVIDIA GLX Module 319.60 Wed Sep 25 14:24:11 PDT 2013
[ 57.899] Loading extension GLX
[ 57.899] (II) LoadModule: “nvidia”
[ 57.899] (II) Loading /usr/lib64/xorg/modules/drivers/
[ 58.159] (II) Module nvidia: vendor=“NVIDIA Corporation”
[ 58.159] compiled for 4.0.2, module version = 1.0.0
[ 58.159] Module class: X.Org Video Driver
[ 58.205] (II) NVIDIA dlloader X Driver 319.60 Wed Sep 25 14:04:14 PDT 2013
[ 58.205] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 58.206] (++) using VT number 1

[ 58.208] (EE) No devices detected.
[ 58.208]
Fatal server error:
[ 58.208] no screens found
[ 58.208] (EE)

So… there’s a device being mapped, the right driver is being modloaded, but once the driver is loaded it
doesn’t recognize the device. Help me Obi-Wan, you’re my only hope!
[This file was removed because it was flagged as potentially malicious] (78.8 KB)

Please see the forum sticky posts about how to generate and attach an nvidia-bug-report.log.gz file.

Whoops, sorry, I thought I’d done that. Here it is!
[This file was removed because it was flagged as potentially malicious] (78.8 KB)

Does adding the appropriate BusID line to /etc/X11/xorg.conf help? Some X servers have trouble when there is more than one graphics device in the system if a bus ID isn’t specified. You can add

BusID "1:0:0"

in the “Device” section, or run “sudo nvidia-xconfig --enable-all-gpus” to have nvidia-xconfig generate it for you.

nvidia-xconfig --enable-all-gpus does not add such a line to the file at all. If I add the line to the file, the xserver is still unable to find a screen, but the data in the log is indeed different and it appears that the driver does more before giving up. I have included the bug report file.
nvidia-bug-report.log.gz (79.6 KB)

Sorry, I forgot it only adds a BusID line if you also use the --separate-x-screens option.

The problem now is that your NVIDIA GPU doesn’t have any display devices connected to it. If I remember correctly, this laptop has an Optimus or hybrid graphics configuration option in its BIOS. Please try rebooting and disabling Optimus. Otherwise, you can try to use either Bumblebee or the RandR 1.4 output provider support described in Chapter 33 of the README.

If I disable Optimus in the BIOS, does the GPU wind up permanently enabled or permanently disabled? The laptop was purchased in order to run code built with the GPU Computing SDK, so if the GPU itself is disabled then I would definitely want to try Bumblebee.

I believe in this case from a quick google search, that option means that Optimus is disabled and it forces the NVIDIA card to be used all the time… give it a shot and see if it works.

I am pleased to report that it does indeed work! Battery lifetime isn’t an issue for this application so I would consider the problem solved. Many, many thanks for the help!