Driver confusion, what do I need for CUDA?

When I downloaded CUDA 4.x, it said I needed a driver version 275.x or more (if I remember right.) Checking what I have on this Lenovo, it’s version 8.17.12.6844 from May 2nd, for a gtx-555m. When I look for updates for Windows 7, it says there aren’t any new drivers. Yet the gtx-555m is said to support CUDA. So does this mean I need to download some older version of CUDA? How would I guess which old one I need? I would post this under the geforce M series area, but I’ve never seen Nvidia reply over there, I don’t think they read that one.

You need the latest nvidia gpu driver. You can get it from here: http://www.nvidia.com/Download/index.aspx?lang=en-us

That worked, maybe.
I say maybe because I found gtx-555m listed in the 285.x driver, downloaded it, installed it, rebooted. Laptop still functioning but when I run exe files located in
ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK 4.0\C\bin\win64\Release
they all report this:
cudaSafeCall() Runtime API error 38: no CUDA-capable device is detected.

Thankfully I have an Intel graphics chip in this laptop, or this thing would dead in the water I guess.

So one more question… do I now have to recompile all the source code myself to get it to recognize my particular Nvidia chip?

Hello,

My guess is that you have to install gpu driver, than reinstall the cuda toolkit and then install the sdk.

yep, tried that to no avail. so I uninstalled all the nvidia cuda, gpu and 285.x driver stuff and rebooted and Windows went out and found my original 268.44 driver and reinstalled it at boot up. Handy since I didn’t keep a copy! Then I downloaded the cuda 3.2 and gpu 3.2 stuff that should work with 268.44, but none of that works either. I still get the dreaded no cuda capable device found message.

Oddly, I went to the GeForce site and had it check automatically for drivers and it reported I have a GT-555m, but then told me it couldn’t find any drivers for that, even though Windows could find the original one!!

This whole setup process is really a mess. Clearly what we need is a way to verify the driver is installed correctly first, before downloading a bunch of other changes to the system and then having some app tell us it can’t find a CUDA device. By then we’ve changed so many things, it’s really hard to guess where the error is.

My next “guess” is to install Linux and see if I can get the hack someone else came up with of adding some identifier to the Linux device driver files to convince the system there really is a GT 555m in there.

One things for sure… if Nvidia wants CUDA to be some sort of mainstream programming technology, they need to smooth out this startup process and make it work reliably.

The procdure is straight forward. First uninstall the previous drivers. Then install the latest gpu driver from here http://www.nvidia.com/Download/index.aspx?lang=en-us (your card is listed), now you can install the cuda toolkit from here http://developer.nvidia.com/cuda-toolkit-40

I think I followed all the instructions to the letter. Sadly I ended up shipping the laptop back, not because I couldn’t get CUDA working, but because it failed a disk drive test. I was willing to keep trying to get the Nvidia drivers working but Lenovo only gives you 21 days to check a laptop out so I was bumping up against that.

Too bad I couldn’t get CUDA working for me. It seems like hacking some of the driver inf files (I think that’s what they were called) would have worked but without clear instructions on how to do it, it was hit or miss.

Thanks for your help nonetheless.