Driveworks 1.2 samples getting CUDA version runtime error

Hi, I had Cuda 9.0 and Driveworks 0.6 installed on a ubuntu x86 machine.
Recently I used the SDK manager to install cuda 9.2 and Driveworks 1.2. Now the 1.2 samples don’t work.

Is there a clean way to remove the cuda 9.0 and driveworks 0.6 installations? They were installed with the previous drive software installer.

Dear pratik.gangwani,

Could you please refer to “Uninstall Steps” below link for your topic?
https://docs.nvidia.com/drive/driveinstall_docs/#developertools/mobile/driveinstall/linux/5.0.5.0b/sdk/install.htm%3FTocPath%3D_____3

Uninstall Steps
To uninstall individual components from the host, run the DriveInstall .run file. At the Component Manager window, choose Uninstall in the Action column for the component you wish to remove.
To fully uninstall DriveInstall for Linux from the host, please run <Install_Dir>/_installer/DriveInstall_Uninstaller in terminal.

Hi Steve,
Unfortunately that now points only to the sdkManager. But I was able to locate the DriveInstall .run file and install the components! Thank you!

Unfortunately, my error still exists:

[5-11-2018 14:9:20] Initialize DriveWorks SDK v1.2.400
[5-11-2018 14:9:20] Release build with GNU 4.8.5 from v1.2.0-rc11-0-ga7f5475
[5-11-2018 14:9:20] Platform: Detected Generic x86 Platform
[5-11-2018 14:9:20] TimeSource: monotonic epoch time offset is 1541444106972456
[5-11-2018 14:9:20] Driveworks exception thrown: DW_CUDA_ERROR: Platform: cannot acquire cuda context : CUDA driver version is insufficient for CUDA runtime version

terminate called after throwing an instance of ‘std::runtime_error’
what(): [2018-11-05 14:09:20] DW Error DW_CUDA_ERROR executing DW function:
dwInitialize(&context, DW_VERSION, &sdkParams)
at /builds/driveav/dw/sdk/samples/freespace/main.cpp:263
Aborted (core dumped)

I’m guessing I need to update my GPU drivers?

Updated the GPU drivers for system to be on branch 410 via apt.

The samples now run. Some of them are a little weird and messed up. Ex. Drivenet is stuck in a super fast loop.

Hi Pratik,

please have a look on our current release notes for DriveWorks: https://docs.nvidia.com/drive/active/5.0.10.3L/pdfs/NVIDIA_DriveWorks_SDK_Release_Notes_1.2.400.pdf

There you do find the “NVIDIA graphics driver version 396 is the suggested driver for X86 platforms”. Therefore, try it with driver version 396 and you should be ready to go.

  • Fabian

Hi Fabian,

Ok I will try to roll back the drivers to 396 this afternoon and will post results. Thanks!

Ok I rolled back to 396 branch. The samples all still work but drivenet is still running very fast and constantly trying to restart.

But everything else works ok.

Hi Pratik,

the Release Notes have been updated by mentioning “NVIDIA Maxwell based GPU [as] minimum”.

In other words the Drivenet sample may fail due to the lack of a Pascal architecture or higher. We expect the Drivenet sample to be the only sample not fitting those minimum requirements.

For a better clarification we might update the Release Notes again.

  • Fabian

Gotcha. Thanks.

We do have a GTX 1080 in that machine and that is Pascal so we should be good there.

Hi Patrik,

glad to hear that.

The upcoming Release Notes will state that the new minimum is Pascal.

  • Fabian