DriveWorks API sample_drivenet dose not work on Host PC (ubuntu 16.04 w/ driveworks)

Hello,

As a new user of NVIDIA DRIVE Platform I am trying to execute basic driveworks samples. Sadly I am struggling with this since I always get the same error for any sample I try to execute in usr/local/driveworks-0.6/bin/ :

& ./sample_drivenet
./sample_drivenet: error while loading shared libraries: libcuda.so.1: cannot open shared object file: No such file or directory

Following this I found libcuda.so.1 in /home//NVIDIA/Drive/5050aL_SDK/DriveSDK/drive-t186ref-linux/lib-target
and checked two things:

  • cuda-9.0 is installed in usr/local/cuda-9.0/

  • I added the path to “libcuda.so.1” in some /etc/ld.so.conf.d/ folder’s files:
    -> in “cuda-9.0.conf”
    -> in “driveworks.conf”
    -> in “nvidia.conf”

    (just to be sure, even if adding it in cuda-9.0.conf is supposed to be enough)

=========== [EDIT] ===================
I also tried the following command:

modprobe nvidia modprobe: FATAL: Module nvidia not found in directory /lib/modules/4.13.0-36-generic

Thank you for your help.

Dear bcollado-bougeard,
It looks like nvidia drivers are not installed on PC. Please install nvidia gpu drivers on your ubuntu platform and run any CUDA sample to verify if CUDA is setup correctly later