Driveworks Cross Compiling Samples for the NVIDIA Drive Platform

Hello,

I am trying to Cross Compile the Driveworks samples for the PX2. I used the documentation that NVIDIA Drive has offered to cross compile. The main problem is that I can’t find the library “cuda-cross-aarch64-9-2”. I don’t know what exactly my problem is or why it can’t find it, but I have tried all these things from the documentation for Cross Compiling.

  • My current system is a x86 Linux machine with Ubuntu 16.04. I have CUDA 9-2 and Driveworks 1.2. I followed all of the steps beforehand installing the libraries:
    libx11-dev
    libxrandr-dev
    libxcursor-dev
    libxxf86vm-dev
    libxinerama-dev
    libxi-dev
    libglu1-mesa-dev
    libglew-dev

  • I have validated my Driveworks install by running the sample using ./sample_drivenet.

  • I have run the hello world example.

  • I am able to compile the Driveworks examples if I am not cross compiling it. -

  • I have then run the same examples that I have compiled and that works too.

  • Driveworks was installed using the SDK manager and have been all properly downloaded several times.

  • Driveworks and CUDA 9-2 have been uninstalled and reinstalled several times as well.

  • Each time I have made also sure that I have completely got rid of all CUDA or NVIDIA libraries before reinstalling so there are no conflicting versions as well and I have been able to run the examples without cross-compiling it.

  • I have also installed Driveworks using the .run files themselves and installed CUDA using the CUDA-toolkit-9-2.

  • In the SDK, the Driveworks cross compiling libraries have been installed properly. The cmake points to the correct folders such as the documentation says, but it still cannot find the correct libraries.

  • I have also added to the .bashrc where CUDA and Driveworks and the installation directory of the SDK/PDK.

  • I have also modified the sources file like the note says in the documentation:

“Some repositories may not have binaries for arm64 and apt-get update causes errors. To prevent these errors, edit /etc/apt/sources.list and files under /etc/apt/sources.list.d/ and add [arch=amd64,i386] into each line starting with deb. Ensure you specify amd64 and not arm64.”

  • cuda-cross-* can’t be found anywhere on my Ubuntu Machine and I can’t find it when I try to sudo apt-get.
  • I also looked online if I can just install it using the .deb file and I can’t find it either.

Does anyone else share a similar issue or know what might be the problem is? If I need to provide more information I would be glad too. Thank you!

Dear kalani,

Could you please help to check DriveWorks SDK Reference -> Samples -> Building the Samples -> Cross-Compiling for the NVIDIA DRIVE Platform(Linux) in DriveWorks doc?

sudo dpkg --add-architecture arm64 sudo apt-get update
$ sudo apt-get install cuda-cross-aarch64-9-2

Hi,

I have tried that multiple times, but I can’t find that library after doing all those steps. I have went through the apt-get lists in my computer and have had the same thing as other people who have installed it. Is there any other advice on this matter?

Dear kalani,

Please refer to below link.
I’ve posted what I’ve done DW cross compilation on DPX2. Thanks.
https://devtalk.nvidia.com/default/topic/1044026/driveworks/cross-compile-failure/